Mouse/Keyboard went bad - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-11-2010, 09:39 PM   #1 (permalink)
Newb Techie
 
Join Date: Jul 2010
Posts: 2
Default Mouse/Keyboard went bad

2 days ago i go on my computer and my keyboard and mouse go bad.

My mouse when i try to DOUBLE click a icon, its as if i right click it, and when i press any kind of a tab in a interbrower, I.E favorites, it wont stay up for more then a split second if im lucky, its very hard for me to click on anything

My keyboard is even worse, i cant type at all for the most part, whatever program im in, lets say firefox, if i try to type in my web bar the starts with a "F" its as if im choosing the "file" option in the top left of the firefox program, every button i press its as if im pressing the hotkey for whatever program im lucky enough to even open.

I scanned for viruses with norton and malaware anti-virus, they both showed nothing, i checked my mouse and keyboard options in control panel, they are all normal and i even reset to defaults, i tried safe mode, same problem there, AND i tried to repiar windows hoping it would recover whatever was lost, its still not working, my last option which i dont want to do is format windows again losing everything.

Please someone try to help, if i did not explain this well enough, ask for more information, its very frustrating and im lost on what to do.

thanks
__________________

prohock9 is offline  
Old 07-11-2010, 10:17 PM   #2 (permalink)
True Techie
 
Alive.777's Avatar
 
Join Date: Jan 2010
Location: QLD, Australia
Posts: 201
Default Re: Mouse/Keyboard went bad

do you have any other mouse/keyboard you can use to test? also, do they have thier correct drivers installed?
__________________

Alive.777 is offline  
Old 07-11-2010, 10:58 PM   #3 (permalink)
Techie Beyond Description
 
MindoverMaster's Avatar
 
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: Mouse/Keyboard went bad

If it's a plug-n-play mouse and keyboard, they only would use default drivers.
__________________
Neowin.net Steam Account
MindoverMaster is offline  
Old 07-12-2010, 08:47 AM   #4 (permalink)
Newb Techie
 
Join Date: Jul 2010
Posts: 2
Default Re: Mouse/Keyboard went bad

yeah i tried using different mix and match sets, tried switching USB ports also
prohock9 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad vista install, can't recover, help please =( mysacrement Microsoft Windows and Software 20 10-29-2008 02:18 AM
bad hard drive but not bad hard drive? servo.tsc Microsoft Windows and Software 16 10-15-2008 10:11 AM
Bad sectors? CalcProgrammer1 Laptops and Notebooks 9 09-07-2008 07:50 AM
bad batch q6600? nukeman8 New Systems | Building and Buying 49 09-04-2008 11:42 AM
BAD BAD problem SiZcO Hardware Repairs and Troubleshooting 3 02-18-2008 12:38 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.