motherboard wont boot - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 05-27-2008, 12:12 PM   #1 (permalink)
lolwut?
 
Join Date: Aug 2007
Posts: 1,139
Default motherboard wont boot

I have a backup sk939 system. It works perfectly. I needed to take out the pcie card, and it had one of those hard as **** latches to get off, and that plus it being a very small midtower and me having massive hands didnt help. Halfway through getting it out i heard a pop. I assumed i just knocked out a cable.

But, i took out EVERYTHING except the essentials. Just mobo psu processor graphics card harddrive. All plugged in. The light on the motherboard saying it has power is lit, but if i hit the power button, it doesent do anything. Ive used other power buttons to no avail.

Do you think i could have shorted the motherboard and that was the popping sound?
__________________

__________________
| Taintedplay | Q6600 | evga gtx 260| XP 32bit
taintedplay is offline  
Old 05-27-2008, 01:28 PM   #2 (permalink)
I feel funny...
 
thirdshiftdj's Avatar
 
Join Date: Oct 2006
Location: Lowell,Ma
Posts: 3,808
Send a message via AIM to thirdshiftdj
Default Re: motherboard wont boot

did you ground yourself and unplug the psu in the back? Stupid questions, I know but just in case.
__________________

__________________
NUFFIN!
thirdshiftdj is offline  
Old 05-27-2008, 08:09 PM   #3 (permalink)
lolwut?
 
Join Date: Aug 2007
Posts: 1,139
Default Re: motherboard wont boot

grounded myself but didnt unplug psu. It was about 5am and i was trying to get it in before sleep, and i guess i forgot. ****. time to go buy a replacement
__________________
| Taintedplay | Q6600 | evga gtx 260| XP 32bit
taintedplay is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
P5K Premium "Proper Boot Device/Insert Boot Media" s-patrol Hardware Repairs and Troubleshooting 3 12-02-2007 12:37 AM
Replacing Motherboard, Help Needed Rask Vann New Systems | Building and Buying 9 11-15-2007 09:40 AM
Boot order question AceWriter System Upgrades 0 10-13-2007 12:29 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.