monitorNo signal on xfx geforce 9600 gso - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-24-2012, 06:02 PM   #1 (permalink)
Newb Techie
 
Join Date: Jun 2012
Posts: 2
Default monitorNo signal on xfx geforce 9600 gso

New video card. When i plug into my computer there is no signal on my monitor. Fan on video card spins, computer turns on with regular 1 beep. this card does not support vga so i got an dvi-i adapter for my vga cable that is connected to the monitor. there is also no 6 pin connecter on the card either. my PSU is 550w.
i switch back to my ati 5450 graphic card, even with the dvi-i adapter plugged in, it works fine. there's visual on the monitor. but when i replug the 9600 gso a couple times still nothing appears on monitor. any suggestions? i hope its not DOA

this is the one i have
http://images.search.yahoo.com/image...1pqhi&fr=moz35
__________________

vweyy is offline   Reply With Quote
Old 06-25-2012, 09:22 AM   #2 (permalink)
Banned
 
Join Date: Apr 2005
Location: n/a
Posts: 2,956
Default Re: monitorNo signal on xfx geforce 9600 gso

Quote:
Originally Posted by vweyy View Post
New video card. When i plug into my computer there is no signal on my monitor. Fan on video card spins, computer turns on with regular 1 beep. this card does not support vga so i got an dvi-i adapter for my vga cable that is connected to the monitor. there is also no 6 pin connecter on the card either. my PSU is 550w.
i switch back to my ati 5450 graphic card, even with the dvi-i adapter plugged in, it works fine. there's visual on the monitor. but when i replug the 9600 gso a couple times still nothing appears on monitor. any suggestions? i hope its not DOA

this is the one i have
Image Detail for - XFX PVT96OYHFC GeForce 9600 GSO Video Card - 512MB, DDR3, PCI-Express ...

Can you put that card back in, turn it on and look upside down from your case, please tell me if your fan is spinning up ?
If it isn't it may not be securely locked into the socket and touching the cases metal frame.
If all else fails call xfx today and see if they'll rma your card, check and see if they might another with a vga socket by the dvi port.
-RockMan- is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xfx geforce 9600 gso no signal problem vweyy Hardware Repairs and Troubleshooting 0 06-24-2012 05:28 PM
GeForce Nvidia 9600 GSO XFX problems desteele94 Hardware Repairs and Troubleshooting 11 07-21-2009 10:15 PM
GeForce 9600 GSO, Thoughts? StealthTools New Systems | Building and Buying 27 04-22-2009 11:20 PM
9600 gso problems Lasue System Upgrades 4 10-18-2008 03:34 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.