Monitor loses signal, keyboard lights turn off after windows splash screen, long delay - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-10-2012, 04:12 PM   #1 (permalink)
Newb Techie
 
Join Date: Jun 2012
Posts: 5
Default Monitor loses signal, keyboard lights turn off after windows splash screen, long delay

Everything works fine except for a little something that is just annoying.
I can deal with it, im just wondering why it would happen.
Im using an SSD to boot up. Everything works fine and fast except when it gets to the Windows Splash screen.
The monitor seems to lose signal and my g15 keyboard's LCD shuts off and i wait for about 6 seconds. After that i can hear the login sound my keyboard LCD turns back on while the monitor goes back to the DVI connection displaying the login screen
Anyone know why this would happen after the windows splash screen?
Is it drivers?
Using an asrock z77 extreme6 MOBO, SSD firmware is updated
__________________

mc02x is offline   Reply With Quote
Old 06-10-2012, 04:38 PM   #2 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,506
Default Re: Monitor loses signal, keyboard lights turn off after windows splash screen, long delay

It's probably loading the drivers for them. Try updating the drivers for video and your keyboard.
__________________

__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is online now   Reply With Quote
Old 06-10-2012, 05:03 PM   #3 (permalink)
Newb Techie
 
Join Date: Jun 2012
Posts: 5
Default Re: Monitor loses signal, keyboard lights turn off after windows splash screen, long delay

I disabled the onboard intel video drivers so it was just my gtx 670 running and it fixed the monitor going no signal. I tried doing the same for my keyboard but there are 3 HID keyboard device drivers under keyboard. When i try to disable, 3 keep getting added. Im guessing this is why my keyboard shuts off for a while during the windows splash screen
mc02x is offline   Reply With Quote
Old 06-10-2012, 05:07 PM   #4 (permalink)
Newb Techie
 
Join Date: Jun 2012
Posts: 5
Default Re: Monitor loses signal, keyboard lights turn off after windows splash screen, long delay

Quote:
Originally Posted by mc02x View Post
I disabled the onboard intel video drivers so it was just my gtx 670 running and it fixed the monitor going no signal. I tried doing the same for my keyboard but there are 3 HID keyboard device drivers under keyboard. When i try to disable, 3 keep getting added. Im guessing this is why my keyboard shuts off for a while during the windows splash screen
EDIT: while my keyboard is not working, neither is the mouse. I have to wait atleast 10 seconds in the login screen for my g15 LCD to turn back on and then the mouse starts working as well
mc02x is offline   Reply With Quote
Old 06-10-2012, 05:15 PM   #5 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,506
Default Re: Monitor loses signal, keyboard lights turn off after windows splash screen, long delay

Do you have a logitech mouse as well?
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is online now   Reply With Quote
Old 06-10-2012, 05:20 PM   #6 (permalink)
Newb Techie
 
Join Date: Jun 2012
Posts: 5
Default Re: Monitor loses signal, keyboard lights turn off after windows splash screen, long delay

Keyboard is a Logitech g15
Mouse is a steelseries xai

its as if the usb ports reset themselves?
mc02x is offline   Reply With Quote
Old 06-10-2012, 05:55 PM   #7 (permalink)
Newb Techie
 
Join Date: Jun 2012
Posts: 5
Default Re: Monitor loses signal, keyboard lights turn off after windows splash screen, long delay

Quote:
Originally Posted by mc02x View Post
Keyboard is a Logitech g15
Mouse is a steelseries xai

its as if the usb ports reset themselves?
Edit: must be my xai mouse.. when i unpluggd it everything loaded fine and there was no delay on my keyboard starting up. plugged it back in the delay was there.
__________________

mc02x is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor loses signal randomly fans blow like crazy or red light appear on Gfx card Fladam Hardware Repairs and Troubleshooting 7 01-03-2010 06:28 PM
monitor loses signal Vonshudo Hardware Repairs and Troubleshooting 8 01-17-2008 11:47 PM
windows xp splash screen bobbyray Microsoft Windows and Software 8 08-02-2005 01:18 AM
Screen freezes - monitor temp loses signal Fritters Monitors, Printers and Peripherals 0 06-03-2005 05:50 AM
Help: Signal takes long to get to monitor Seboko Monitors, Printers and Peripherals 0 06-03-2005 04:00 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.