May have ruined the pc I spent months saving up for. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 05-23-2014, 12:48 PM   #1 (permalink)
Newb Techie
 
Join Date: May 2014
Location: England
Posts: 13
Default May have ruined the pc I spent months saving up for.

So, i just got a new graphics card, as i was previously running on an integrated system. I inserted it into the PCIE slot, turned on the pc, and the GPU's fan started turning. I took this as a good sign. Inserted the CD for installing the drivers onto the card, and experienced a error message explaining that it was the wrong cd for the card. Now, i was determined to overcome this ****-up, and so decided to install the drivers manually, the only way i knew how. Through the device manager. I went into the device manager, clicked on the "Display adapter" bit and the only thing shown was my old intergrated GPU (radeon 8570HD)

I then turned to the internet, and after searching "new graphics card doesn't come up in the device manager" i saw a post stating that you first must disable the integrated GPU through the bios. So i rebooted went into the bios, and disabled the integrated card. I saved and exited the bios, and then realised my blunder. I now have no display what so ever as my integrated GPU is disabled, and if i plug my DVI into the card OR the motherboard i still get no display

PLEASE HELP
__________________

spoonjarspoon is offline   Reply With Quote
Old 05-23-2014, 12:57 PM   #2 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,505
Default Re: May have ruined the pc I spent months saving up for.

Reset your BIOS settings by unplugging your computer, press the power button a few times, and remove the silver coin battery for about 30 seconds. Then reinsert the battery, plug back in, and boot up.
__________________

__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline   Reply With Quote
Old 05-23-2014, 12:57 PM   #3 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,276
Default Re: May have ruined the pc I spent months saving up for.

Reset your bios. There will be a jumper to do this or you can unplug the watch battery that is on the motherboard.

If you're getting no display through the card then make sure it is seated properly in the slot and that the PCI-E power connector is properly inserted. For future reference, the IGP on an APU does not need to be disabled to run a dedicated card.
__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Old 05-23-2014, 01:16 PM   #4 (permalink)
Newb Techie
 
Join Date: May 2014
Location: England
Posts: 13
Default Re: May have ruined the pc I spent months saving up for.

Where can I find the silver coin battery?
spoonjarspoon is offline   Reply With Quote
Old 05-23-2014, 01:59 PM   #5 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,276
Default Re: May have ruined the pc I spent months saving up for.

On the motherboard.
__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Old 05-23-2014, 02:04 PM   #6 (permalink)
Newb Techie
 
Join Date: May 2014
Location: England
Posts: 13
Default Re: May have ruined the pc I spent months saving up for.

Quote:
Originally Posted by spoonjarspoon View Post
Where can I find the silver coin battery?
Don't worry I've found it. Thanks for your help.
spoonjarspoon is offline   Reply With Quote
Old 05-23-2014, 03:13 PM   #7 (permalink)
Newb Techie
 
Join Date: May 2014
Location: England
Posts: 13
Default Re: May have ruined the pc I spent months saving up for.

Hey guys me again. I've unplugged my machine, pressed power button, taken out motherboard battery, waited 30 seconds, re-inserted battery, and plugged back in multiple times and still get no display when i plug my DVI into my motherboard.
spoonjarspoon is offline   Reply With Quote
Old 05-23-2014, 03:21 PM   #8 (permalink)
Build Guru
 
PP Mguire's Avatar
 
Join Date: Dec 2004
Location: Fort Worth, Texas
Posts: 28,276
Default Re: May have ruined the pc I spent months saving up for.

Did you take the video card out first? I'll also ask what are your specs?
__________________
"Resolution is just a number." #Ubisoft
Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire PSN = PP_Mguire

Access to my Plex PM me.
PP Mguire is offline   Reply With Quote
Old 05-23-2014, 03:30 PM   #9 (permalink)
Newb Techie
 
Join Date: May 2014
Location: England
Posts: 13
Default Re: May have ruined the pc I spent months saving up for.

Yes i did. Spec wise, I have 8gb RAM, AMD A8 6600k processor, and Radeon 8570HD intergrated GPU. The graphics card i bought (on a limited budget) was a palit 650 1gb (Overclocked edition). To be honest, i'm not that worried about the graphics card right now, i just want my pc up and running
spoonjarspoon is offline   Reply With Quote
Old 05-23-2014, 03:42 PM   #10 (permalink)
Knowitall!
 
strollin's Avatar
 
Join Date: May 2011
Location: N. Calif.
Posts: 632
Default Re: May have ruined the pc I spent months saving up for.

Once you get the integrated graphics working again, go to the new gpu's mfr website and download the latest drivers for your gpu from there.
__________________

strollin is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
When saving a file in Microsoft visio 2010 it is saving the webpage way to small. D-Rocks Microsoft Windows and Software 2 03-30-2011 01:09 PM
How much have YOU Spent on Newegg.com? undefined Off Topic Discussion 20 12-28-2007 11:50 PM
Dell ruined computers PoisonPorkchop Overclocking and Modding 1 03-22-2005 05:58 PM
How many hours have you spent on Tech-Forums Elite Bullet Off Topic Discussion 30 12-13-2004 04:26 PM
ruined my mobo with a scratch!!!! Satellite Monitors, Printers and Peripherals 4 06-07-2004 09:38 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:59 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.