LCD-TFT Issue - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 11-26-2007, 07:13 AM   #1 (permalink)
Newb Techie
Join Date: Apr 2006
Posts: 17
Angry LCD-TFT Issue

OK, little background story:

I've been buying Samsung screens for years. I've had one since LCD-TFT's first hit out in the mainstream (a 17" cost me almost a grand). Now, my next screen was a Samsung as well (purchased over a year ago). I haven't had problems with either screens - the original is still being used by a relative and is running just fine after 6-7 years!

And now comes today: I went through two Samsung screens: the 931BW and the 206BW and both have had stuck pixels. I tried the "tapping" method, the "massaging method," even several different programs that flash the RBG colours on the spot or the entire screen. On top of that, I was even desperate enough to try power cycling the monitor. To no avail, none of the methods have worked. Of course Samsung won't RMA it and neither will the store; not enough stuck/dead pixels.

To be perfectly honest, I could ignore the pixel and carry on without it, but it really bothers me that I pay good, hard earned money for a faulty product. I do not care what any of the companies say - a monitor should not have these problems and just because they don't want to give a 0 pixel guarantee is no reason to sell products with sub-par quality assurance. If their previous models didn't give problems, but their new products do, it leads me to believe that their product quality is going down hill [MASS PRODUCTION].

I will never buy another Samsung screen again. I repeat, I will NEVER buy another Samsung screen again. They have lost a life-long customer.

I know a pixel here and there might not be a big issue, but it's the principle. You may good money for a product that is supposed to have high-quality, and you end up getting screwed 2 monitors in a row (within days of each other).

If anyone has any suggestions or any resolution, please feel free to let me know!
originate is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LCD horrible performance... TimmyVanilly Hardware Repairs and Troubleshooting 7 10-15-2007 02:47 AM
Vista, Lost Planet, and 8800GTS issue. TheOtis Hardware Repairs and Troubleshooting 3 07-30-2007 04:15 PM
Sound Issue Dieo Hardware Repairs and Troubleshooting 11 07-13-2007 02:19 PM
TV Card issue AntonOle Hardware Repairs and Troubleshooting 1 05-17-2007 07:31 AM
Weird IE7 Issue reubix Microsoft Windows and Software 1 05-02-2007 01:54 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:12 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.