laptop water damage - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-23-2007, 10:55 PM   #1 (permalink)
Newb Techie
 
Join Date: Oct 2005
Posts: 3
Default laptop water damage

I have a Toshiba satellite model 1405-S151. I accidently spilled some water on it (keyboard). Now the power switch doesnt turn on. If i plug it in it still charges and the led at the bottom light up but the switch doesnt work.

Any ideas for turn on?
__________________

antivirus6613 is offline  
Old 03-23-2007, 11:01 PM   #2 (permalink)
Ultra Techie
 
kfc469's Avatar
 
Join Date: May 2006
Posts: 928
Send a message via AIM to kfc469
Default Re: laptop water damage

You really should have let it dry out for a month before trying to do anything with it. The fact that you plugged it in was, no offense, really really stupid. If the computer wasn't already short circuited before you plugged it in, running that kind of voltage through there certainly did it. I'm afraid that there isnt much you can do for it now.
__________________

__________________

kfc469 is offline  
Old 03-23-2007, 11:19 PM   #3 (permalink)
Retired.
 
peterhuang913's Avatar
 
Join Date: Dec 2005
Location: Los Angeles, California
Posts: 8,076
Send a message via AIM to peterhuang913
Default Re: laptop water damage

Quote:
Originally Posted by kfc469 View Post
You really should have let it dry out for a month before trying to do anything with it. The fact that you plugged it in was, no offense, really really stupid. If the computer wasn't already short circuited before you plugged it in, running that kind of voltage through there certainly did it. I'm afraid that there isnt much you can do for it now.
lmao he signed up for TF to get rejected...
__________________


My computer uses 1.5A-load, .8A-idle, .65A-standby, .05A-turned off on 125V.
"The spaces between your fingers were created so that another's could fill them in."
Quote:
Originally Posted by Norcent View Post
I need to stop using the internet.
peterhuang913 is offline  
Old 03-23-2007, 11:34 PM   #4 (permalink)
Newb Techie
 
Join Date: Oct 2005
Posts: 3
Default Re: laptop water damage

guys its been out for about 6 months i asked my friends and they say they dont know .Just recently i got more time which is why i am trying to fix it. I plugged it in for the first time maybe 1-2 months ago to try it to see if it dried out. it charged but button did not turn on.
antivirus6613 is offline  
Old 03-25-2007, 03:20 PM   #5 (permalink)
Master Techie
 
Alvin.C's Avatar
 
Join Date: Jun 2004
Location: United Kingdom
Posts: 2,580
Default Re: laptop water damage

Hello,

Most probably died from being shorted I'm afraid.
__________________
Alvin.C
linkedin.com/in/alvinwkchan

|Gaming PC| |Dell Latitude E7250| |Macbook Air 13" (Mid 2013)|
|Windows 10 Pro (x64)| |Intel Core i5-6600 @ 3.3 GHz| |MSI NVIDIA GeForce GTX 1080 Gaming X| |Noctua NH-D15S CPU Cooler| |Gigabyte GA-Z170MX-GAMING 5 mATX Motherboard| |Samsung 840 Pro 256GB SSD| |Corsair Vengeance LPX 16GB DDR4-SDRAM| |OCZ ModXStream Pro 700W Modular PSU| |NZXT Vulcan Micro ATX Case|
Alvin.C is offline  
Old 03-25-2007, 10:07 PM   #6 (permalink)
I know <html>, do you?
 
SYL\X/3K's Avatar
 
Join Date: Aug 2006
Location: 127.0.0.1
Posts: 1,646
Send a message via AIM to SYL\X/3K Send a message via Yahoo to SYL\X/3K
Default Re: laptop water damage

if you know how to solder then open her up and look for any burnt marks on the motherboard or any capacitors that seem odd or bumpy.

8\10 times this happens your pretty $crewed
__________________
P3 Setup- Intel 1.0ghz , 512Mb SDRAM , ATI 9200 128MB, 2x 40GB HD, Asus CUSL-LV

.....:::::POST Troubleshooting Steps.___.My Rig.___.Memory Test:::::.....
SYL\X/3K is offline  
Old 03-26-2007, 06:55 AM   #7 (permalink)
True Techie
 
Join Date: Aug 2006
Posts: 100
Default Re: laptop water damage

hello, please go to a professional.
__________________

__________________
http://i15.photobucket.com/albums/a3...21472copy2.jpg
Front- Polk Rti4
Surrounds- Bose 161
Center-None
Subwoofer- 10" Pioneer driver, dayton 1.0 cuft enclosure, SA240 240W plate amp
Onkyo TX-SR304
SoundBlaster Live! 5.1
AtomicAudio is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:11 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.