Laptop soundcard stopped working - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 03-04-2011, 10:04 AM   #1 (permalink)
Newb Techie
Join Date: Mar 2011
Posts: 2
Default Laptop soundcard stopped working

Hey guys new to these forums as I've been able to fix most problems myself but this one has me beat, hence me asking the experts.

My laptop is an acer aspire 5520 running windows vista home premium.

I've looked in system devices on the device manager . i' ve noticed that HD audio controller is not installed and i think thats the cause of my problem when i am trying to reinstall my realtek HD audio device driver it didn't worked and there an error code ''10''.the sound, video and game cotrollers root tree is gone.and there's one thing when i am scanning my system for any hardware changes there's no devices scanned not like the other devices they were able to scan by my system.

I've tried reinstalling the drivers but that hasn't worked. Any advice appreciated.

Dagnew is offline  
Old 03-04-2011, 10:25 AM   #2 (permalink)
Techie Beyond Description
MindoverMaster's Avatar
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: Laptop soundcard stopped working

Try driversweeper. Install it, and reset into safe mode. Run driversweeper, take off any realtek drivers. Boot back into regular windows, and install drivers again.

If that doesnt work, I'm afraid your sound is busted or disconnected somehow.

__________________ Steam Account
MindoverMaster is offline  
Old 03-04-2011, 04:25 PM   #3 (permalink)
Newb Techie
Join Date: Mar 2011
Posts: 2
Default Re: Laptop soundcard stopped working

Thanks for your help, was going to try that but when I went to boot up the laptop again it keeps coming up with an error an won't get past the windows start up recovery, saying windows cannot fix this problem, think it's given up haha
Dagnew is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
can't WoL, just stopped working ibexpiotr Computer Networking and Internet Hardware 3 12-10-2009 08:19 AM
Just stopped working... WarrenX Hardware Repairs and Troubleshooting 1 04-20-2009 04:11 AM
PC stopped working :/ Phrantic Hardware Repairs and Troubleshooting 4 01-11-2007 05:32 PM
Alt + F4 Stopped working rockmeisster Microsoft Windows and Software 4 09-26-2003 09:02 AM
ICS stopped working neb1211 Microsoft Windows and Software 2 05-30-2003 08:40 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.