Techist - Tech Forum

Techist - Tech Forum (http://www.techist.com/forums/)
-   Hardware Repairs and Troubleshooting (http://www.techist.com/forums/f77/)
-   -   Just built computer, smoking when plugged in.. (http://www.techist.com/forums/f77/just-built-computer-smoking-when-plugged-187694/)

Clynt 10-10-2008 03:48 PM

Just built computer, smoking when plugged in..
 
So I ordered this with a video card and everything else. I thought I put everything together right, lol. But when I went to plug the computer in, I heard something blow and smoke started coming from the power supply I think. Now when I plug it in nothing happens, and nothing when I press the power button. Going to assume I fried almost everything lol. I checked after and everything seemed to be connected properly... so I'm not sure what happened.

Evolv 10-10-2008 04:23 PM

Re: Just built computer, smoking when plugged in..
 
Yea, definetly power supply blew. Happened to my cousin and ended up frying his motherboard, because of the Raidmax power supply that came with his case. So more than likely you'll need a new board. Thats why you should never use the cheap power supplies that come with a case.

Cat_Returns 10-10-2008 04:57 PM

Re: Just built computer, smoking when plugged in..
 
man that sucks dude. call tigerdirect and tell them that you got a defective psu, i am pretty sure they will replace everything

KurrentEweser 10-10-2008 07:24 PM

Re: Just built computer, smoking when plugged in..
 
The link says: THIS ITEM IS CURRENTLY UNAVAILABLE. You may not be the only one with problems.

veedubfreak 10-10-2008 08:33 PM

Re: Just built computer, smoking when plugged in..
 
Oh man, you let the magic blue smoke out. Thats not good. These days if the cable fits in the plug, its almost guaranteed to be properly plugged up. My guess is theres some defective gear going on.


All times are GMT -5. The time now is 03:55 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.