It's broken. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 06-01-2008, 03:40 AM   #1 (permalink)
Super Techie
 
Join Date: Jan 2006
Location: Perth, Australia
Posts: 327
Default It's broken.

My family PC is broken D:
It starts when a HDD isn't plugged in.
;but when it does start with a HDD plugged in, it says it can't find a file on Windows : <Windows Root>/system32/hal.dll

PC SPECS:
CPU: Intel Pentium 4 : 2.8 Ghz
RAM: 2048MB DDR400
GPU: GeForce FX 5600XT AGP
HDD: Samsung 80GB IDE
MoBo (I think): Intel D865PERL
PSU: MPT-301 300I've tried a different hard-drive, but it just turns off. The fans start and the LED stays on, but that's it. It just won't work D:

Thanks in advance :]

Jordan.
__________________

__________________
InfernoDeals
sinci is offline  
Old 06-01-2008, 05:33 AM   #2 (permalink)
Repeat Offender
 
superdave1984's Avatar
 
Join Date: Aug 2006
Location: South Fulton, TN
Posts: 1,980
Default Re: It's broken.

Is this the drive windows was originally installed on? If so, try a repair install. If not, there's your problem. You can't swap hard drives between PC's unless they are nearly identical. It's not like a CD drive. The file that is missing is for the HAL (hardware abstraction layer) it is created when windows is installed. Windows installs for the hardware that is present at the time. If you change critical parts like hard drive or MOBO, you will have to start from scratch.
__________________

__________________
Change the world. Of one person. Today.

If your equation requires either a complex combination of variables to get the desired result OR you can't seem to get the result regardless of the variables....it ain't your variables, it's your constant.
superdave1984 is offline  
Old 06-01-2008, 08:57 AM   #3 (permalink)
Super Techie
 
Join Date: Jan 2006
Location: Perth, Australia
Posts: 327
Default Re: It's broken.

The Samsung is the hard-drive with Windows.
I only swapped them to see if that was the problem.

+they both have windows on them.
I'll try a repair install and get back to you (:


Thanks.

edit
I went to repair install, but now it doesn't power on at all.
Everything is plugged in.
With or without a HDD it just won't start D:
Fans don't power, LED stays off.
nothing =[

edit2
I figured I'll may as well get a new PC
or something.
look into it . =]
could a mod please
*CLOSE POST*
__________________
InfernoDeals
sinci is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to fix broken file associations Osiris Microsoft Windows and Software 0 09-22-2007 01:36 PM
Is AMDís 65nm SOI process broken? Kharn Monitors, Printers and Peripherals 1 08-21-2007 01:29 PM
Session Cookies = BROKEN JaJa789NeO Microsoft Windows and Software 3 06-26-2007 04:08 PM
HP Omnibook xe4100 Laptop, Broken DC Jack, Can the laptop be powered any other way? callmewilson Hardware Repairs and Troubleshooting 2 05-07-2007 01:00 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.