Issues with new video card - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Thread Tools Display Modes
Old 10-11-2013, 06:56 PM   #1 (permalink)
True Techie
Join Date: Oct 2008
Location: Wheatfield, NY
Posts: 112
Send a message via AIM to Kozar927
Default Issues with new video card

Today I picked up a Lenovo ideacentre K450 gaming PC
Market Specs:
CPU: i5-4430 3.0
RAM: 8gigs DDR3
OS: windows 8
Stock GPU: some crappy Nvidia 2gigs
let me know if more info is needed.

With it I purchased a:
GPU: RADEON R7770 Ultra OC edition 1GB DDR5
PSU: CX600M 600W
to run the card

All day I have had nothing but problems here. The people at the store said all parts are compatible etc.

At first I had no idea about windows 8 and secure boot so I turned that off and finally machine booted with the new card. No problems untill I installed drivers. On reboot the PC wont load video untill windows loads so im blind during BIOS boot and then when windows loads its starts flickering between no signal and signal with a a black screen. Nothing happens it does this forever. Im going crazy here. I put in stock card and it boots, and I remove all driver but still the same story when putting new card in. Have tried to troubleshoot this for hours, and I really need to get operational. I work from home and I dont know what to do anymore. Thanks in advanced for any insite. Ill provide what ever details are requested to help troubleshoot this. Thanks

Kozar927 is offline   Reply With Quote
Old 10-12-2013, 09:17 AM   #2 (permalink)
Build Guru
PP Mguire's Avatar
Join Date: Dec 2004
Location: DFW Texas
Posts: 26,029
Default Re: Issues with new video card

First thing to do in any new GPU install is uninstall all video drivers and related software be it Nvidia or AMD. Next up run a program called driver sweeper to make sure these drivers are out.
Install your new card and boot into the bios to make sure the onboard video is disabled (it should do that automatically, but need to make sure).
Then download and install the latest AMD drivers that are NOT beta.
"Resolution is just a number." #Ubisoft Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire Mechwarrior Online = Thunderson PSN = PP_Mguire

Need Descent and Mechwarrior buddies!
If I helped you, give a thanks! ↓
Access to my Plex PM me.
PP Mguire is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:45 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.