Internal network card no longer works - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 04-01-2011, 01:01 PM   #1 (permalink)
Newb Techie
Join Date: Apr 2011
Posts: 1
Default Internal network card no longer works


My computer (ASUS CM5675 desktop) was acting perfectly until I decided to install Ubuntu. After installation I noticed that when I booted to Windows 7 that the "disconected network cable" icon popped up. I checked the Device Manager to see if the card is enabled (which it is) and to see if Windows thinks its functioning properly (which it does). I tried using different cables, plugging directly into the modem, disabeling and reenabeling the card, unistalling the driver then reinstalling, and even completly reformatiing the entire harddrive to start fresh but still have the same problem. Also, to further prove that something is wrong, the network status light on my switch will blink for which ever port I plug the desktop into, whereas everything else (modem, laptop, xbox 360) gives a solid status light (indicating everything is ok).

Is there anything I can do, or is stock internal network card (Realtek PCIe GBE Family Controller) toast?

phillipbritain is offline  
Old 04-01-2011, 01:25 PM   #2 (permalink)
Hyper Techie
Abstract Hero's Avatar
Join Date: Apr 2010
Location: Phoenix, AZ
Posts: 1,842
Default Re: Internal network card no longer works

Honestly if you really went through all that troubleshooting there are 2 options.

Re seat the card. Physically take it out, boot, shutdown, (don't have to but sometimes it oddly helps) and plug it in again.

If that didnt work something is indeed broken either the card or possibly the Pci slot. You can always try the card in another slot.
- AMD FX8320 @ 4.2Ghz - ASRock Fatal1ty 990FX Killer - G.Skill Ripjaws X 8gb -
- Asus Strix GTX 970 - Corsair Neutron GTX - Corsair TX 750 -
- Cooler Master HAF XB - Corsair H105 -
- Asus VG248QE - Corsair M60 & K90 -
Abstract Hero is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vista Standby/Sleep no longer works.. andrewsvalesen Microsoft Windows and Software 5 01-07-2008 11:30 AM
Router no longer works & weird TraceRT ShackledPhoenix Computer Networking and Internet Hardware 10 04-14-2007 04:22 PM
Laptop mouse section no longer works. gamerunknown Hardware Repairs and Troubleshooting 6 09-25-2006 01:27 PM
The internal network works, but I can not get onto the internet Harper Computer Networking and Internet Hardware 10 12-09-2005 04:05 AM
USB no longer works huizilopochtli Monitors, Printers and Peripherals 8 06-23-2005 08:46 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:47 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.