Install Video Card Problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 04-28-2006, 12:47 PM   #1 (permalink)
Junior Techie
Join Date: Sep 2005
Posts: 59
Default Install Video Card Problem

Hi I just bought a new video card (Apollo GeForce 6800 128 MB AGP) I put it in and turn on the computer, but all I get is one long BEEP sound. The screen though stays black, I don't even get the bios.

When I plug my old card back in everything works fine, so I need help please. Thank you for any input you can provide.

Ares82 is offline  
Old 04-28-2006, 01:12 PM   #2 (permalink)
True Techie
Join Date: Apr 2006
Posts: 245

are you sure you seated it properly? and the card COULD be DOA

jdhore1 is offline  
Old 04-28-2006, 01:38 PM   #3 (permalink)
Junior Techie
Join Date: Sep 2005
Posts: 59

I plugged it in tightly I double checked, and tried doing it more then once. So it's deffinatly not that.

DOA? As in broken? I sure hope not, I just bought the **** thing. **** it and I was so psyched to play Oblivion today. Is there anything else that it could be? I really don't want to have to send this thing back and wait another week for a replacement.
Ares82 is offline  
Old 04-28-2006, 01:40 PM   #4 (permalink)
Wizard Techie
CrazeD's Avatar
Join Date: Feb 2006
Location: Maine
Posts: 3,736
Send a message via AIM to CrazeD Send a message via MSN to CrazeD

I'm pretty sure that card has a molex connection on it, did you plug that in?

Make sure you seat it really well. My friend has a GeForce 6600 256mb card that you really have to push hard to get it to seat properly.

Intel Q9400 | Gigabyte EP45-UD3P | G.Skill 2x2GB DDR2 1000 | XFX HD5870

Need website help? PM me!
CrazeD is offline  
Old 04-28-2006, 01:50 PM   #5 (permalink)
Newb Techie
Join Date: Apr 2006
Posts: 20

i'm not sure about that particular card.. but i've had some cards that need a power cable plugged directly into the card itself.. the same type as you would use for, say, a harddrive or cd-rom.

if it doesn't have one then chances are it is DOA. if you bought it in town, just take it back and say that it doesn't work and exchange for a new one.

if bought online, an RMA shouldn't take too long
MMH is offline  
Old 04-28-2006, 02:06 PM   #6 (permalink)
Newb Techie
Join Date: Apr 2006
Posts: 27

is the monitor saying no signal?
VooDoo27 is offline  
Old 04-28-2006, 02:13 PM   #7 (permalink)
Junior Techie
Join Date: Sep 2005
Posts: 59

Well MMH you hit it right on the nail, I can't believe how dumb I was. Turns out that this vid card needs to be plugged into the internal power supply.

In my defense though, my old card didn't need it and that joke of a manual that came with the card didn't mention anything about hooking it up to the internal power supply. In fact the only way I figured it out was by looking at the box and I saw under requirements that it said "Needs 4-pin hard drive power connector from internal power supply".

Anyways I hooked it up now and it's working. On to installing Oblivion

Thanks for the help guys.

Ares82 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:11 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.