I startup my computer and nothing appears on screen... - Page 3 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 01-06-2007, 02:33 PM   #21 (permalink)
Newb Techie
 
Join Date: Jan 2007
Posts: 14
Default

Ahh thanks dude lol, I've seen those on all types of electronics but didn't know what they were. I'm gonna take a look in my mobo tonight to see if theres any damage like that. I pray that its just a PSU problem. I want to check how many watts my PSU is capable of. I'm starting to suspect it may be because my videocard is not getting enough power for it to work although it doesn't require an extra power connecter which is the reason I purchased it.
__________________

GeminEye2k5 is offline  
Old 01-07-2007, 01:40 PM   #22 (permalink)
Newb Techie
 
Join Date: Jan 2007
Posts: 14
Default

I checked my mobo last night and I didn't see any visible damage on it....how can I check to see if my cpu is damaged?
__________________

GeminEye2k5 is offline  
Old 01-09-2007, 09:35 AM   #23 (permalink)
Newb Techie
 
Join Date: Jan 2007
Posts: 14
Default

can someone help me?
__________________

GeminEye2k5 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.