I my mobo just died but not sure - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 09-06-2012, 05:25 PM   #1 (permalink)
Monster Techie
 
Drogos's Avatar
 
Join Date: Apr 2007
Posts: 1,415
Default I my mobo just died but not sure

Hello I was playing guild wars 2 wen I just lost video feed.
I though that it was my video card so I grabed mu bothers in laws and still no video.
Now im using a rampage 3, first gen i7 960,gtx 560 2gb,10gb ram,12/gb ssd,650 watt corsair.
Now wen I push the button all the fans and lighs oncluding cpu and gpu turn on.
But no video feed I did tryed a different card slot aswell.
I did notice no all the light on the mobo the reset and power button r led and the bios switch but all the error leds on the mobo dont come on to tell me whats wrong .
What do u guys think? Im writing from my phone im a little desperate atm l

Thanks in advance
__________________

Drogos is offline   Reply With Quote
Old 09-06-2012, 08:22 PM   #2 (permalink)
Monster Techie
 
Drogos's Avatar
 
Join Date: Apr 2007
Posts: 1,415
Default Re: I my mobo just died but not sure

i was able to get my sis laptop on loan for now. but it looks like i might be getting new mobo and cpu. i went to comp usa and talked to one of the techs and he says it sounds like the mobo is done i have feeling it is to don't know what else it could be.
i was going to buy a mobo to try but they dont sell ones for first gen i7 so im thinking of using my amazon credit to buy new cpu and mobo . any input is a appreciated
Drogos is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Has my 5770 died? bentini1uk Hardware Repairs and Troubleshooting 7 05-05-2010 07:44 AM
My G5 died! :'( CrazeD Monitors, Printers and Peripherals 12 06-28-2007 08:05 PM
Hard Drive Died?! - Or Mobo Failure? Dante_Caligari Hardware Repairs and Troubleshooting 4 01-29-2007 03:38 PM
Help! Comp died on me Mozes123 Hardware Repairs and Troubleshooting 2 01-02-2007 12:35 AM
Mobo died? The51 Monitors, Printers and Peripherals 8 05-05-2005 09:45 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.