I cant seem to get my livestreams to load - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Thread Tools Display Modes
Old 08-12-2014, 06:52 PM   #1 (permalink)
Newb Techie
Join Date: Jul 2014
Location: US
Posts: 28
Default I cant seem to get my livestreams to load

ok so first, im not sure where i would post something like this so i thought i would start here.

When i go to watch a livestream on Twitch the stream fails to load but i can still chat.
Im not sure whether it is my computer or my internet. PLZ help.

Rocketman2798 is offline   Reply With Quote
Old 08-13-2014, 01:03 AM   #2 (permalink)
Junior Techie
Join Date: Jun 2014
Location: United States of America
Posts: 64
Default Re: I cant seem to get my livestreams to load

To help out, we'd need more details like your computer specifications and your ISP, Internet speed, etc.

battleof3 is offline   Reply With Quote
Old 08-13-2014, 01:36 AM   #3 (permalink)
Build Guru
PP Mguire's Avatar
Join Date: Dec 2004
Location: DFW Texas
Posts: 26,035
Default Re: I cant seem to get my livestreams to load

Browser, AV information, and whether or not all drivers/software is update is more appropriate.
"Resolution is just a number." #Ubisoft Origin/Steam = PP_Mguire Twitch = pp_mguire Instagram = ppmguire Mechwarrior Online = Thunderson PSN = PP_Mguire

Need Descent and Mechwarrior buddies!
If I helped you, give a thanks! ↓
Access to my Plex PM me.
PP Mguire is online now   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant seem to get onto my netgear router ip address noobie123 Computer Networking and Internet Hardware 2 09-02-2012 05:20 PM
Fake FBI Ransomare. Cant seem to get rid of it Hellasweet Viruses, Spyware and Malware 2 07-06-2012 09:36 AM
cant seem to get anywhere with this virus lrdwolfie Viruses, Spyware and Malware 1 02-13-2011 10:18 AM
CPU Idle/Load temps seem strange kiyotaka Hardware Repairs and Troubleshooting 0 11-10-2005 03:54 PM
Some sites don't seem to load... freechus9 Microsoft Windows and Software 12 12-23-2003 07:08 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.