Help! My Psu Got Burned - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-19-2006, 06:37 AM   #1 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 2
Send a message via Yahoo to jake_27
Unhappy Help! My Psu Got Burned

help my problem goes like this first i bought a secondhand PALIT GeForce FX 5200 128mb from a friend then i inserted it on my AGP Slot (ECS PT800CEA MOTHERBOARD CELERON 2.4) after that i switch on the computer then its start but an awful smell came out from my cpu then the computer stops working, i switch it on again but its not working. my question is did a video card desroyed my psu and is there anything else got burned except for my psu. PLEASE I NEED YOUR HELP THANKS A LOT.
__________________

jake_27 is offline  
Old 07-19-2006, 10:53 AM   #2 (permalink)
LA1
Super Techie
 
Join Date: Jul 2006
Location: eastcoast
Posts: 453
Default

Ummmmm It all depends on what went wrong. Did you have to remove the card cover plate on the back of the pc so the card will stick out ? possibly left a screw or the plate inside the pc on a board of mainboard. You could have pinched a wire when closing the case. You will have to opem it up and find out what happened.
__________________

__________________
LA1 is offline  
Old 07-20-2006, 03:04 AM   #3 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 33
Default

Power supply issue perhaps.
short circuit or some other technical reason but i wont be able to help more that those 2 little ideas.
Solitary is offline  
Old 07-20-2006, 03:20 AM   #4 (permalink)
Master Techie
 
Join Date: Apr 2005
Posts: 2,306
Default

you prolly did not put it in the slot all the way and it prolly shorted something out
__________________
Lonewolf5460 is offline  
Old 07-22-2006, 11:23 AM   #5 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 2
Send a message via Yahoo to jake_27
Default

thank you for the reply friends, anyways my mobo is useless anymore so i have to buy a new one and also a new psu. lucky for me only my mobo and psu got burned my cpu, ddr and other hardware is still working again thnx.
jake_27 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.