Help Me!! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 03-01-2007, 08:18 PM   #1 (permalink)
Newb Techie
 
Join Date: Mar 2007
Posts: 4
Default Help Me!!

OKay, so around 2 weeks ago my computer shut off on my in the middle of my game, so i rushed to turn it back on, but it whouldnt turn on. I thought it was my power supply so i bought a new one and got a new cord for it, but it still didnt work. So then i thought, maybe it was my power button, so i got a new case. Still doesnt work! What is wrong with my computer. I really want to play my games but cant figure it out! AWW! What do i do?
__________________

Montee is offline  
Old 03-02-2007, 09:00 AM   #2 (permalink)
Junior Techie
 
Join Date: Aug 2006
Posts: 98
Default

Specs would help? :/
__________________
AMD 3700+ 64-Bit at 2.8ghz
Gigabyte K8 Triton Series nForce 4 SLI Motherboard
e-GeForce 8800GT 512mb
1GB DDR400 Hyper X
200+100+80GB HDD
19" Acer WideScreen LCD
AMD 3200+ 64 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:45 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.