Has my 5770 died? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 05-04-2010, 08:39 PM   #1 (permalink)
Newb Techie
 
Join Date: Apr 2010
Posts: 6
Default Has my 5770 died?

Ok problem goes like this, i've built a new rig about a month ago and today im just sat browsing the web and the monitor goes blank so i turn off and back on and get a no signal message.
I Hard reset to have my computer not boot and the monitor to just come up with the no signal error.

I've tried re-seating my 5770 to no avail and the only way i can boot is to remove graphics card and plug monitor directly into mobo. Also tried un-installing and reinstalling drivers but i don't believe this to be a software issue at all.

Up untill this moment i have ran games fine and have been really happy with my new system. The question remains has the XFX HD5770 just randomly died at only a month old or is there a more sinister underlying problem, any help, comments or advice would be greatly appreciated, thanks.

Stephen
__________________

bentini1uk is offline  
Old 05-04-2010, 08:46 PM   #2 (permalink)
Ultra Techie
 
memory's Avatar
 
Join Date: Feb 2008
Location: Southern Indiana
Posts: 991
Default Re: Has my 5770 died?

Do you hear any beeps when you try to boot?
__________________

__________________
Antec 1200
Intel Core i7 920@2.7ghz
Gigabyte X58A-UD3R
Noctua NH-D14
ATI Radeon HD5870
Corsair 6gb DDR3 1600
Corsair 850HX PSU
OCZ Vertex 2 120gb SSD
WD Caviar Black WD5001AALS 500gb
Windows 7 Pro 64bit


I know someone who pressed yes...
His home and family Combusted Spontaneously...
memory is offline  
Old 05-04-2010, 08:49 PM   #3 (permalink)
Newb Techie
 
Join Date: Apr 2010
Posts: 6
Default Re: Has my 5770 died?

no i dont hear any beeps when i try to boot with the 5770 in. Just all case/cpu/gpu fans start then nothing
bentini1uk is offline  
Old 05-04-2010, 08:57 PM   #4 (permalink)
Newb Techie
 
Join Date: May 2010
Posts: 3
Default Re: Has my 5770 died?

I have a 5770 as well. I don't really know how to solve your issue. Does your motherboard have another PCIe 2.0 slot? If so, try putting it in that one. My 5770 is manufactured by Sapphire and runs pretty just with the 850 MHz clock. I would contact XFX, as your card should still be under warranty.

If for some reason it's not, you could try putting it in the oven but I would do this only as a last resort.

Holy crap, it worked! Dead video card resurrected! - [H]ard|Forum
Monolithic is offline  
Old 05-04-2010, 09:02 PM   #5 (permalink)
Ultra Techie
 
memory's Avatar
 
Join Date: Feb 2008
Location: Southern Indiana
Posts: 991
Default Re: Has my 5770 died?

Do you have a spare video card you could try in place of that one?
__________________
Antec 1200
Intel Core i7 920@2.7ghz
Gigabyte X58A-UD3R
Noctua NH-D14
ATI Radeon HD5870
Corsair 6gb DDR3 1600
Corsair 850HX PSU
OCZ Vertex 2 120gb SSD
WD Caviar Black WD5001AALS 500gb
Windows 7 Pro 64bit


I know someone who pressed yes...
His home and family Combusted Spontaneously...
memory is offline  
Old 05-04-2010, 09:09 PM   #6 (permalink)
Newb Techie
 
Join Date: Apr 2010
Posts: 6
Default Re: Has my 5770 died?

sadly i don't, the only thing i can do is try to return the card to the shop and swap for a new one. but also don't want to take it back for them to test it and say its working fine.
bentini1uk is offline  
Old 05-04-2010, 09:38 PM   #7 (permalink)
Ultra Techie
 
memory's Avatar
 
Join Date: Feb 2008
Location: Southern Indiana
Posts: 991
Default Re: Has my 5770 died?

I assume you do not have another pci-e slot.

You could try to start it up without the 6 pin plug for the card and see if you get any beeps. Also try different sticks of ram in different slots.
__________________
Antec 1200
Intel Core i7 920@2.7ghz
Gigabyte X58A-UD3R
Noctua NH-D14
ATI Radeon HD5870
Corsair 6gb DDR3 1600
Corsair 850HX PSU
OCZ Vertex 2 120gb SSD
WD Caviar Black WD5001AALS 500gb
Windows 7 Pro 64bit


I know someone who pressed yes...
His home and family Combusted Spontaneously...
memory is offline  
Old 05-05-2010, 07:44 AM   #8 (permalink)
Newb Techie
 
Join Date: Apr 2010
Posts: 6
Default Re: Has my 5770 died?

Update, Returned my card to the shop, scan and they instantly replaced with a new one, installed and all working correctly. Thanks for any comments.
Stephen
__________________

bentini1uk is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
PowerColor 5770 Eyefinity 5 Edition Muffin Man New Technology and Products 7 03-06-2010 03:19 AM
8800GTS 320MB vs Radeon 5770 1GB Mr. Switch New Systems | Building and Buying 3 12-26-2009 06:03 PM
Early HD 5770 Review Muffin Man New Technology and Products 7 10-14-2009 03:45 AM
Radeon HD 5770 and 5750 coming in October, November Trotter New Technology and Products 1 09-15-2009 07:15 PM
sys died not booting into BIOS lilbay Hardware Repairs and Troubleshooting 3 07-06-2007 09:47 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:58 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.