half power problems - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 06-26-2006, 04:16 AM   #1 (permalink)
Master Techie
 
Join Date: Jun 2005
Posts: 2,134
Default half power problems

for the 2nd time, my computer did the thing where 1/2 the devices do not recieve power.

all the case fans, opticals, and HDDs did nothing on boot, and the computer found nothing to boot to.

i originally thought this could have been a dodgy molex, but seeing as the HDDs didn't have power, (sata) then the problem seems to be from within the PSU itself.

i think i am going to have to buy a new one.... what do you guys think?
__________________

joshd is offline  
Old 06-26-2006, 07:56 AM   #2 (permalink)
Monster Techie
 
MrCoffee's Avatar
 
Join Date: Feb 2006
Location: UK
Posts: 1,858
Default

We think you're right
__________________

__________________
Intel core I7 920
GA-EX58-UD3R
6GB OCZ platinum 1600
XFX HD4890
Noctua nh-u12p
Corsair HX520
Antec 300
Samsung 1TB F1 Spinpoint
Samsung SM2443BW 24"
MrCoffee is offline  
Old 06-27-2006, 10:31 PM   #3 (permalink)
Junior Techie
 
Join Date: Jun 2006
Posts: 88
Default

Well I think the same and if it's the second time that this happens you should buy an AVR(Auto Voltage Regulator) to help prevent another PSU to damage.
PR Gamer is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.