Graphics card fans work but no picture - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 09-15-2011, 09:16 PM   #1 (permalink)
Web Programmer
 
murdocsvan's Avatar
 
Join Date: Jun 2007
Location: Surrey, UK
Posts: 896
Default Graphics card fans work but no picture

I've just built a new rig with an ASRock Z68 Extreme 4 and a Gainward GTX 570. Everything's plugged in, and when I power it on the fans on the card spin up, but i cant get any image from it. I can get an image from the motherboards built in VGA no problem though.

Is the graphics card broken?
__________________

__________________
PHP + MYSQL, ASP.Net + C# with SQL, WCF, Python, XHTML + CSS, HTML5, JavaScript, jQuery, Flash + ActionScript 3, XML, SVG.

Web Developer Portfolio
murdocsvan is offline  
Old 09-15-2011, 09:22 PM   #2 (permalink)
Techie Beyond Description
 
MindoverMaster's Avatar
 
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: Graphics card fans work but no picture

What are your system specs?

Did you plug in the PCI-E power cord? Could also be your PSU that doesn't have enough power.
__________________

__________________
Neowin.net Steam Account
MindoverMaster is offline  
Old 09-15-2011, 09:26 PM   #3 (permalink)
Newb Techie
 
Join Date: Jun 2011
Location: Leeds, England
Posts: 19
Default

Maybe try the card in another computer if possible to check? But it may not be the graphics card, what PSU do you have? This may be an issue as if it's not getting enough power it may not work.

-sorry posted before I saw moms post but same question
happyh1ppo is offline  
Old 09-15-2011, 09:27 PM   #4 (permalink)
Web Programmer
 
murdocsvan's Avatar
 
Join Date: Jun 2007
Location: Surrey, UK
Posts: 896
Default Re: Graphics card fans work but no picture

ASRock z68 Extreme 4 Motherboard
i7 2600k Quad Core@3.4Ghz Processor
8gb(2 x 4gb) 1600mhz Corsair Vengence Ram
Gainward GTX 570 GS Graphics Card
OCZ 600w SXS Power Supply
__________________
PHP + MYSQL, ASP.Net + C# with SQL, WCF, Python, XHTML + CSS, HTML5, JavaScript, jQuery, Flash + ActionScript 3, XML, SVG.

Web Developer Portfolio
murdocsvan is offline  
Old 09-15-2011, 09:45 PM   #5 (permalink)
Web Programmer
 
murdocsvan's Avatar
 
Join Date: Jun 2007
Location: Surrey, UK
Posts: 896
Default Re: Graphics card fans work but no picture

I used the asustek PSU calculator and it said at minimum i should have 600w. Wouldn't PSU problems cause other symptoms other than just the graphics card though?
__________________
PHP + MYSQL, ASP.Net + C# with SQL, WCF, Python, XHTML + CSS, HTML5, JavaScript, jQuery, Flash + ActionScript 3, XML, SVG.

Web Developer Portfolio
murdocsvan is offline  
Old 09-15-2011, 10:11 PM   #6 (permalink)
Techie Beyond Description
 
MindoverMaster's Avatar
 
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: Graphics card fans work but no picture

You could just get a bad PSU out of the hat, but that is uncommon.

600W should be fine. Could be the amperage not being enough, on the single 12v rail. I'll let someone else get that, but I've seen it in comments about building logs.
__________________
Neowin.net Steam Account
MindoverMaster is offline  
Old 09-15-2011, 10:32 PM   #7 (permalink)
Web Programmer
 
murdocsvan's Avatar
 
Join Date: Jun 2007
Location: Surrey, UK
Posts: 896
Default Re: Graphics card fans work but no picture

Just tried plugging in my old 8800GT and that seems to work fine, so at this point i'm guessing it's the graphics card.
__________________
PHP + MYSQL, ASP.Net + C# with SQL, WCF, Python, XHTML + CSS, HTML5, JavaScript, jQuery, Flash + ActionScript 3, XML, SVG.

Web Developer Portfolio
murdocsvan is offline  
Old 09-15-2011, 10:42 PM   #8 (permalink)
Techie Beyond Description
 
MindoverMaster's Avatar
 
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: Graphics card fans work but no picture

Yeah, pretty much. Try that 570 in a different desktop, if you can.
__________________
Neowin.net Steam Account
MindoverMaster is offline  
Old 09-15-2011, 10:57 PM   #9 (permalink)
Web Programmer
 
murdocsvan's Avatar
 
Join Date: Jun 2007
Location: Surrey, UK
Posts: 896
Default Re: Graphics card fans work but no picture

Sadly don't have another one to test it in, nor do i have any friends with computers that can support it. Think i'll return it, considering i only got it a few days ago, and if the new one doesnt run either then i'll upgrade and get a better PSU.
__________________
PHP + MYSQL, ASP.Net + C# with SQL, WCF, Python, XHTML + CSS, HTML5, JavaScript, jQuery, Flash + ActionScript 3, XML, SVG.

Web Developer Portfolio
murdocsvan is offline  
Old 09-15-2011, 11:03 PM   #10 (permalink)
Techie Beyond Description
 
MindoverMaster's Avatar
 
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: Graphics card fans work but no picture

Yeah, that'd be best. Nothing lost.
__________________

__________________
Neowin.net Steam Account
MindoverMaster is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphics card, fans and software Vaersyth Laptops and Notebooks 8 04-01-2008 02:20 AM
Will this graphics card work with this pc? Relay System Upgrades 7 03-08-2007 02:18 PM
Graphics Card Temperature Idle at 64 degrees (picture inside) v930 Hardware Repairs and Troubleshooting 1 08-15-2006 12:56 AM
New graphics card, now DVD doesn't work zak1976 Monitors, Printers and Peripherals 10 03-22-2005 01:05 PM
Nvidia 5200 128 mb graphics card: My fan wen Kapoot do they sell replacement fans? setherstine Overclocking and Modding 2 05-17-2004 06:59 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.