Fried Power supply unit??? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 05-12-2009, 10:50 PM   #1 (permalink)
Newb Techie
 
Join Date: May 2009
Posts: 13
Default Fried Power supply unit???

ok so after 10 hours or building my rig, wiring everything up, figuring it all out by reading directions and surfing web, when i turned it on everything started to run beutifully then about 5 seconds later wires started smoking. i shut down the computer immediately. 3 questions; will all my other hardware be fried? ; Why did this happen and how can i make sure it doesnt happen again? and whats a good affordable PSU im running a budget maybe under 60 bucks.

Specs;
Intel core 2 duo e8400
Asus p5q se/r
500gb HD
Cd/dvd
Mid tower case
Geforce 9800GT
What power supply should i get?
__________________

mdavey316 is offline  
Old 05-13-2009, 12:01 AM   #2 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: Fried Power supply unit???

1. Some hardware could have been affected by the meltdown. You will have to check them out and inspect them.

2. Why? It could have been a short, could have been grounded, could have been a under powered PSU trying to run to much. We cant say. Could have been a defective PSU. we really dont know.

3. check the Hardware Stickies.

Power Supplies
In Depth PSU Guide: Please Read.
http://www.techist.com/forums/f76/up...-guide-137927/

They will be your best source of information.
__________________

__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 05-13-2009, 08:47 PM   #3 (permalink)
Oldie but a goodie
 
oldskool's Avatar
 
Join Date: Jun 2008
Location: Maine, USA
Posts: 1,762
Default Re: Fried Power supply unit???

Quote:
Originally Posted by mdavey316 View Post
ok so after 10 hours or building my rig, wiring everything up, figuring it all out by reading directions and surfing web, when i turned it on everything started to run beutifully then about 5 seconds later wires started smoking. i shut down the computer immediately. 3 questions; will all my other hardware be fried? ; Why did this happen and how can i make sure it doesnt happen again? and whats a good affordable PSU im running a budget maybe under 60 bucks.

Specs;
Intel core 2 duo e8400
Asus p5q se/r
500gb HD
Cd/dvd
Mid tower case
Geforce 9800GT
What power supply should i get?
As Mak said, you will have to look everything over, but as for why it happened, it could be one of many reasons. Are you sure everything was connected properly? I fried a mobo once eons ago because of misconnecting a plug. Never made that mistake again since that time, as I check, check, and check again before flipping the switch. And even then, mistakes can happen.

Chances are you connected everything ok, because the Molex plugs, mobo connectors, etc., are keyed such that everything should fit one way only, although you still have to be careful because some connectors if forced will "fit", but companies have made great strides in improving ease of connecting equipment these days.

Sounds like a short to me, I think Mak said it too. Any other details you have found out since your last post ?
oldskool is offline  
Old 05-13-2009, 11:45 PM   #4 (permalink)
Newb Techie
 
Join Date: May 2009
Posts: 13
Default Re: Fried Power supply unit???

well fortunetly ive purchased a new power supply and got an RMA for the old one. i got a 700watter this time. set it up, pluged it in and bang everything is perfect. the only thing i can thing of is if u plug a 4 pin molex and a sata power connecter at the same time into a Hard drive... would you blow **** up? cuz looking back...i think i stupidly did that, and my hard drive was also faulty today which i had to replace. But luckily everythings good now installing windows 7 as we speak! thanks for the help guys
mdavey316 is offline  
Old 05-14-2009, 12:09 AM   #5 (permalink)
Oldie but a goodie
 
oldskool's Avatar
 
Join Date: Jun 2008
Location: Maine, USA
Posts: 1,762
Default Re: Fried Power supply unit???

Great news that it is all working out for you.

According to Wikipedia (not the be-all knowledge base but still has good info):

Quote:
The SATA standard also specifies a new power connector. Like the data cable, it is wafer-based, but its wider 15-pin shape prevents accidental mis-identification and forced insertion of the wrong connector type. Native SATA devices favor the SATA power-connector over the old four-pin Molex connector (found on most PATA equipment), although some SATA drives retain older 4-pin Molex in addition to the SATA power connector.
SOURCE: Serial ATA - Wikipedia, the free encyclopedia

So, yes it's possible it was a bad thing, if it wasn't intended to use both molex and sata connections.
oldskool is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Supply Messing Up Sneakymage66 Hardware Repairs and Troubleshooting 3 05-10-2009 06:53 PM
Power Supply unit question Dakhathsk New Systems | Building and Buying 3 02-04-2009 06:06 PM
Help replacing a power supply mobkon System Upgrades 4 11-13-2008 03:09 AM
7 VSB from power supply?? GregJ Hardware Repairs and Troubleshooting 1 05-14-2007 11:36 AM
Can I use ATX Power supply without -5 volt out jar99 Monitors, Printers and Peripherals 2 05-12-2007 02:28 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.