FPS Loss - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-26-2012, 06:04 PM   #1 (permalink)
Newb Techie
 
Join Date: Oct 2011
Posts: 34
Default FPS Loss

Ok so I have been randomly having FPS issues when I play World of Warcraft. It's fine one minute and then I come back and its choppy as hell. I thought that it was WoW related so I did everything I could possibly do which included deleting a lot of stuff and updating my drivers. Still.....the problem continued. The only way to fix it is to restart my computer then everything is fine...at least for awhile. Today it started to do it when I was watching movies on my PC. So now I know it has nothing to do with WoW and everything to do with the video card. But like I said I have uploaded new drivers countless times and it's only 3 months old. I don't know what else to do and I need some help here. System info is below........

AMD Phenom II x4 965 Black Edition
16GM RAM DDR3
NVIDIA GeForce GTX 550ti
__________________

skullknight10 is offline   Reply With Quote
Old 06-26-2012, 06:18 PM   #2 (permalink)
 
patonb's Avatar
 
Join Date: Jan 2005
Location: In Gov't Regulated Cubical
Posts: 9,745
Default Re: FPS Loss

Have you checked your temperatures?
__________________

__________________
Foldie = i5 6600kMSI Z170A M5 EVGA 970 SC Corsair H100 Corsair hx520 2x8gb GSkill Corsair 650D
Woohoo = L5639 @3.1Ghz EVGA SR-2 gtx 260-216 Hyper 212+ Corsair 1050hx 6x2gb Corsair XMS3 Blackhawk Ulra
Alienware 18 - SLI 770M 4700mq 16Gig

patonb is offline   Reply With Quote
Old 06-27-2012, 05:56 PM   #3 (permalink)
Newb Techie
 
Join Date: Oct 2011
Posts: 34
Default Re: FPS Loss

Quote:
Originally Posted by patonb View Post
Have you checked your temperatures?
35C / 95F right now and it's doing the Lag thing.
skullknight10 is offline   Reply With Quote
Old 06-27-2012, 05:57 PM   #4 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,516
Default Re: FPS Loss

Try updating your drivers; or back-dating if you're on the newest ones.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline   Reply With Quote
Old 06-27-2012, 08:39 PM   #5 (permalink)
Newb Techie
 
Join Date: Oct 2011
Posts: 34
Default Re: FPS Loss

I said that I already updated my drivers..........
skullknight10 is offline   Reply With Quote
Old 06-27-2012, 08:42 PM   #6 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,516
Default Re: FPS Loss

Sorry, missed that. Updated DirectX and such?

Were those just GPU temps you posted? What about CPU temps?
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is offline   Reply With Quote
Old 06-27-2012, 10:00 PM   #7 (permalink)
Wizard Techie
 
Join Date: May 2011
Posts: 3,077
Default Re: FPS Loss

Adware/malware can also bring any pc to it's knees. Have you checked for anything using up your resources?
__________________

Joe C is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FPS issues in FPS games Imperium Laptops and Notebooks 16 05-29-2010 01:59 PM
Loss of FPS after upgrade shan1784 New Systems | Building and Buying 7 01-08-2009 11:49 AM
Overclocked GPU and now my FPS dropped to 20FPS from 60 FPS? pinoy3000 New Systems | Building and Buying 5 08-27-2007 01:51 AM
loss of FPS braz Hardware Repairs and Troubleshooting 13 04-30-2007 09:02 PM
FPS drop and Sound loss Punzz Monitors, Printers and Peripherals 2 12-30-2003 11:44 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.