Flash Drive Problem - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-30-2006, 07:23 PM   #1 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 7
Send a message via AIM to Davis Send a message via Yahoo to Davis
Default Flash Drive Problem

I just bought a Sandisk Cruzer Micro 1GB flash drive. I have two working USB ports and it doesn't work in either. My other Attache Flash Drive works though.

When I go into device manager and look at its properties it says "This device cannot start. (Code 10)" The computer knows it is a USB Mass Storage Device but there is a yellow ! over the USB icon in device manager. I've uninstalled it a few times and uninstalled all the USB drivers. All were re-installed normally but the flash drive still wont work.

Anyone have any ideas for what I should do?

PS: Win XP with SP2
__________________

Davis is offline  
Old 07-31-2006, 03:59 AM   #2 (permalink)
Wizard Techie
 
Jorsoft's Avatar
 
Join Date: Feb 2004
Location: Oakdale, MN
Posts: 4,581
Default

I've never had a problem installing a flash drive on a windows 2000/xp machine. I'd try the flashdrive in another pc and if it doesn't work look into exchanging it.
__________________

__________________
Jorsoft is offline  
Old 07-31-2006, 11:33 AM   #3 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 7
Send a message via AIM to Davis Send a message via Yahoo to Davis
Default

Thats what I was thinking. It should instal no problem. I'll try it in my cousins computer tomorrow. Thanks for the reply.
Davis is offline  
Old 08-01-2006, 11:19 AM   #4 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 7
Send a message via AIM to Davis Send a message via Yahoo to Davis
Default

I went to my cousins house and it works fine in his computer. Is there any chance that one of my Windows files is messed up?
Davis is offline  
Old 08-04-2006, 02:38 PM   #5 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 7
Send a message via AIM to Davis Send a message via Yahoo to Davis
Default

Anyone else know what might be wrong with it?
Davis is offline  
Old 08-04-2006, 02:40 PM   #6 (permalink)
Junior Techie
 
Join Date: Jul 2006
Posts: 40
Send a message via AIM to jdon285 Send a message via Yahoo to jdon285
Default

Are you using front usb ports? Try one of the back ones and see if it works.
jdon285 is offline  
Old 08-05-2006, 01:49 PM   #7 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 7
Send a message via AIM to Davis Send a message via Yahoo to Davis
Default

I've tried all my USB ports, front and back.
Davis is offline  
Old 08-05-2006, 01:54 PM   #8 (permalink)
Law
Wizard Techie
 
Law's Avatar
 
Join Date: Aug 2005
Location: the data closet
Posts: 4,200
Default

Did you say that another flash drive work and not this particular one? It might be trying to use the same drive letter as the other one, what you can do is go to computer management (right click on My Computer and select Manage). Go to disk management, plug in the old flash drive, than change the drive letter to something else that isn't use (like Z). Now try the new flash drive.
Law is offline  
Old 08-05-2006, 02:05 PM   #9 (permalink)
Junior Techie
 
Join Date: Aug 2006
Posts: 45
Send a message via AIM to Ov3RBliK1
Default

Try unplugging your other USB devices and then see if it works.
__________________
<font size=1>
ASUS P4R800-VM / Intel P4 2.0GHz 478
ATi X800XT All-In-Wonder 256MB AGP 8x
1GB (2 x 512MB) Kingston PC3200 DDR400
Creative SB Audigy 2 ZS Gamer
Western Digital 120GB + 40GB
Razer Diamondback Plasma / Ideazon ZBoard
Ov3RBliK1 is offline  
Old 08-06-2006, 10:48 AM   #10 (permalink)
Newb Techie
 
Join Date: Jul 2006
Posts: 7
Send a message via AIM to Davis Send a message via Yahoo to Davis
Default

I have only been plugging one in at a time so the drive letter shouldn't matter. And I've tried unplugging all the USB devices and it still didn't work.
__________________

Davis is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.