Techist - Tech Forum

Techist - Tech Forum (http://www.techist.com/forums/)
-   Hardware Repairs and Troubleshooting (http://www.techist.com/forums/f77/)
-   -   Failing PSU? (http://www.techist.com/forums/f77/failing-psu-265069/)

FoxiStatis 03-05-2013 04:50 AM

Failing PSU?
 
My computer is constantly freezing, I've RMAed the board, I've tested the RAM, replaced my HDD, formatted several times.

Basically my computer under heavy load and sometimes generally idle will freeze and the music/sound will skip over and over. Then it goes back to normal, there is no blue screen or anything. I've looked it up and people were relating those issues to a bad power supply. Any opinions?

carnageX 03-05-2013 01:33 PM

Re: Failing PSU?
 
Could be PSU or possibly could be drivers (sound, network, video, etc.).

-RockMan- 03-06-2013 01:56 AM

Re: Failing PSU?
 
Quote:

Originally Posted by carnageX (Post 2025305)
Could be PSU or possibly could be drivers (sound, network, video, etc.).

Even if it is not his hardware drivers, could the cpu be at fault here ?
Could be overheatwise or the cpu is more of a issue then he realizes.

DistraughtSysop 03-06-2013 09:04 AM

Re: Failing PSU?
 
Quote:

Originally Posted by FoxiStatis (Post 2025170)
My computer is constantly freezing, I've RMAed the board, I've tested the RAM, replaced my HDD, formatted several times.

Basically my computer under heavy load and sometimes generally idle will freeze and the music/sound will skip over and over. Then it goes back to normal, there is no blue screen or anything. I've looked it up and people were relating those issues to a bad power supply. Any opinions?

What are your specs?


All times are GMT -5. The time now is 01:21 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2018, vBulletin Solutions, Inc.