External HDD stopped working...need help urgently!!! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-13-2007, 05:09 AM   #1 (permalink)
krazy Techie
 
krazyq's Avatar
 
Join Date: Aug 2006
Location: Minnesota
Posts: 8,059
Default External HDD stopped working...need help urgently!!!

Hey guys, i have a Seagate 160gb ext hdd.
I have almost the whole thing filled up with movies,music, IMP DOCS, school assignments...etc

I was using it yesterday perfectly fine...but then i was fixing a buddies pc buy reinstalling xp and a bunch of other stuff. I tried using my ext hdd on his pc but it wouldnt show on my computer even though i could hear the xp doing when something goes into the usb port.

On my pc, same thing...on the bottom toolbar and in device manager it shows that the hdd is there, but i cant find it in my computer to open it.

I really hope i dont have to format this or this isnt corrupt...i cant afford to loose any data on this..
Any help would be really appreciated.

Thanks
__________________

__________________
Intel Core i5-4670K
ASRock Z97 Anniversary
8 GB G.SKILL Ripjaws
MSI GTX 1070 Gaming X
Sandisk Ultra II 960GB + Samsung 850 EVO 500GB + 2TB + 1TB WD Black
Samsung Note 8
2TB White PS4 Pro, PS3, Switch & New 3DS XL
65" LG OLED C7P
BenQ 27" XL2720Z
krazyq is offline  
Old 10-13-2007, 08:26 AM   #2 (permalink)
Master Techie
 
Preacher's Avatar
 
Join Date: Aug 2006
Location: Ra'anana, Israel
Posts: 2,395
Default Re: External HDD stopped working...need help urgently!!!

I had this yesterday too .... I just reconnected to a different USB port but i bet you did that too.
__________________

__________________
www.heavyportrayals.com - Lifting one stone at a time.
Preacher is offline  
Old 10-13-2007, 01:18 PM   #3 (permalink)
krazy Techie
 
krazyq's Avatar
 
Join Date: Aug 2006
Location: Minnesota
Posts: 8,059
Default Re: External HDD stopped working...need help urgently!!!

Quote:
Originally Posted by Preacher View Post
I had this yesterday too .... I just reconnected to a different USB port but i bet you did that too.
yeah...i did.
__________________
Intel Core i5-4670K
ASRock Z97 Anniversary
8 GB G.SKILL Ripjaws
MSI GTX 1070 Gaming X
Sandisk Ultra II 960GB + Samsung 850 EVO 500GB + 2TB + 1TB WD Black
Samsung Note 8
2TB White PS4 Pro, PS3, Switch & New 3DS XL
65" LG OLED C7P
BenQ 27" XL2720Z
krazyq is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
External HDD Question Riznarf Hardware Repairs and Troubleshooting 3 09-20-2007 11:07 AM
Quick External HDD Question Riznarf New Systems | Building and Buying 0 09-18-2007 04:39 PM
External hdd Static_11 New Systems | Building and Buying 12 09-17-2007 12:14 AM
Sound Randomly Stopped Working? gamerz Computer Audio and Multimedia 3 07-20-2007 09:34 AM
Network connection stopped working!? farmboy1984 Hardware Repairs and Troubleshooting 4 04-28-2007 05:31 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:14 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.