external hardrive failure - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 09-23-2005, 06:41 AM   #1 (permalink)
Join Date: May 2005
Posts: 20
Default external hardrive failure

i have an iomega 120gb external desktop drive. it connects via usb 2.0 and has been working perfectly for 8 months. however when i plug it in now, my computer takes ages to pick it up, and furthermore, the drive switches itself on and off constantly every minute or so. when the drive is not connected to my computer it not longer switches off by itself. when i connected it to another computer, that computer froze until i disconnected it. what's wrong???
oneforall is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:35 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.