External Hard Drive PROBLEMS HELP!!!! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 02-19-2006, 08:50 PM   #1 (permalink)
Newb Techie
 
Join Date: Feb 2006
Posts: 3
Default External Hard Drive PROBLEMS HELP!!!!

Ok, so I had been movin some files over to my external hard drive mainly pics, videos, and ripped CDs.........but anyways I go to get a picture off of it and when I go to turn it on nothin happens. I try again still nothing, but a blue light blinks on then off.........If i hold the power button down the light jus goes on and off. What can I do to get the files back? Its nothing major, but I got a ton of pics on there that I would really hate to lose

Any help would be greatly appreciated........Thanks
__________________

Saleen357 is offline  
Old 02-20-2006, 08:41 PM   #2 (permalink)
Newb Techie
 
Join Date: Aug 2004
Posts: 36
Send a message via AIM to drewrockshard Send a message via Yahoo to drewrockshard
Default

Well, if it's a minor thing. Just unplug the power adapter to kill all power to the device; although I usually don't recommend this, sometimes with technology, you just have to cut the cord.

Are you using a western digital media center hard drive (external)?

First try what I said above, and keep posting replies.
__________________

drewrockshard is offline  
Old 02-21-2006, 03:09 PM   #3 (permalink)
Newb Techie
 
Join Date: Feb 2006
Posts: 3
Default

Yes it is a Western Digital............I tried unpluggin it and usin a different outlet still same thing It wont boot up.

I opened the case ( I know I voided warranty) and plugged it into my computer, but it wouldnt recognize it any ideas????
Saleen357 is offline  
Old 02-21-2006, 04:15 PM   #4 (permalink)
Newb Techie
 
Join Date: Aug 2004
Posts: 36
Send a message via AIM to drewrockshard Send a message via Yahoo to drewrockshard
Default

I had the same problem. Close the case back up and try to put it back together exactly the way you found it. Don't mention it to western digital. You need a replacement.

I had the same problem and had to get a full exchange, which was a bum, because i only had it for two weeks and it crapped out on me. It was under the original warranty and it was replaced with a new one, and it has worked successfully ever since. if you look in my old posts (just do a search on my name - drewrockshard - ) and you will see it happened to me too.

So contact them, and dont let them know you voided the warranty.
drewrockshard is offline  
Old 02-21-2006, 06:19 PM   #5 (permalink)
Newb Techie
 
Join Date: Feb 2006
Posts: 3
Default

Well I want my pics and stuff off here................Any way that is possible?
Saleen357 is offline  
Old 02-22-2006, 11:12 AM   #6 (permalink)
Newb Techie
 
Join Date: Aug 2004
Posts: 36
Send a message via AIM to drewrockshard Send a message via Yahoo to drewrockshard
Default

no, i lost everthing sorry.
__________________

drewrockshard is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:25 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.