DVD-ROM Issue - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 10-16-2005, 09:55 AM   #1 (permalink)
Newb Techie
Join Date: Oct 2005
Posts: 2
Question DVD-ROM Issue


I recently purchased Black & White 2. It says on the box "PC DVD-ROM, ONLY DVD COMPATIBLE", which was no problem for me as we have what I think is a DVD Drive (it has the logo DVD-Rom and is a separate 'CD eater' to the one below with the logo "Compact Disc" which usually is the one I use for games).

Firstly, I put the Black & White 2 CD into the Disc drive (which I usually use for games), it starts making a strange noise, as if its scratching/scanning it, the only thing i could roughly describe it as is a group of grasshoppers making that noise they make.

I then tried it in the DVD-ROM drive, it sounds alot better but theres still a subtle 'scanning' noise and nothing happens.

On both occasions, i've tried looking in 'My Computer' and cleaning the disk, but nothing prevails.

I thought it must be a problem with the disc, but I gave it to a neighbour to try and they put the disc into drives on 2 computers, one worked and the other didn't, so it cannot be the disc if it works on their computer.

I believe its something to do with the DVD-ROM drive, i've put several movies into it and nothing happens, and when i try opening a movie player it just says "Insert a DVD", which is strange as at least a month ago, movies played perfectly well in the DVD-ROM drive.

Perhaps I need to install something to get it working? It cannot be broken as I have done nothing to it and it opens and closes fine, I did recently install a new ATI Radeon 9500 graphics card though.

I'd really appreciate your help with this.

Take Care,


LokiMerc is offline  
Old 10-16-2005, 10:58 AM   #2 (permalink)
Newb Techie
Join Date: Oct 2005
Posts: 2

Sorry for the double post but I think I may have found the problem.

If you look at this screenie, the DVD ROM drive seems to be disabled, which is obviously the problem.

I tried updating the driver, allowing it to connect the the internet update thing, but it was unable to find anything on the windows update or my computer.

I also clicked 'Properties' and it says:

This device is disabled. (Code 22)

Click Enable Device to enable this device.
I clicked 'Enable' but it says 'Windows was unable to enable this device'.

I'd appreciate your help.

Thanks. Sorry for the double post but I think I may have found the problem.
Attached Images
File Type: jpg dvd rom problem.jpg (32.4 KB, 16 views)
LokiMerc is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:07 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.