DVD Playback - No Sound - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 04-23-2008, 10:57 PM   #1 (permalink)
True Techie
Join Date: Sep 2005
Posts: 203
Default DVD Playback - No Sound

I'm encountering problems playing back DVDs on my laptop in both my Windows XP and Linux (Ubuntu 8.04 Beta) installs. In Linux, it simply will not read the disc (I have the codecs). In Windows, it plays the DVD video part, but without audio. It plays back most other media formats fine (all the ones I've tried). I tried uninstalling and reinstalling the IDE channel the player is on and made sure it was set on DMA mode. Right now, it says "Multi-Word DMA Mode 2" which seems odd, but it repeatedly enters that mode. It's sort of annoying. Any advice?

Tried VLC, Windows Media Player 11, and some proprietary software that came on a few discs. It's not just one disc either - as far as I can tell, it's all of them.

EDIT: Added Windows version.

trekkie00 is offline  
Old 04-23-2008, 11:06 PM   #2 (permalink)
Master Techie
eyeCpc's Avatar
Join Date: Apr 2007
Posts: 2,074
Default Re: DVD Playback - No Sound

Which version of Windows? For XP WMP 10 is the one to go with seeing all kinds of support for dvd playback and various video file types as well. In Vista you are "encouraged" by MS to buy a 3rd party player like Roxio's Media Player or Cyberlink's PowerDVD in order to play dvds.

You can try all players but if the software/drivers for a sound card or onboard if used are not on fully that would be one thing to consider.

eyeCpc is offline  
Old 04-23-2008, 11:14 PM   #3 (permalink)
Call me Mak or K
Mod Emeritus
KSoD's Avatar
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: DVD Playback - No Sound

Well for Ubuntu i would say wait till tomorrow. 8.04 is going final. So you can get support for it.

In XP get codecs. KLite, CCCP, AC3Filter or Vista Codec Pack (yes it runs on XP). That should solve your sound issues.
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows Vista Discussion Tyler1989 Microsoft Windows and Software 2568 05-04-2008 02:52 PM
Sound Card Tips EricB Computer Audio and Multimedia 2 02-18-2008 12:37 AM
HDTV DVD playback, sound issue Dakhathsk Off Topic Discussion 2 01-04-2008 11:23 PM
Our Ventrilo Server Is Up And Running! mikesgroovin Off Topic Discussion 237 11-15-2007 08:46 PM
AMD Phenom X4 CPU Prices Emerge b1gapl New Systems | Building and Buying 123 11-12-2007 01:03 AM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:39 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.