Doesn't power on - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 09-25-2008, 07:05 PM   #11 (permalink)
Greg's Avatar
Join Date: Dec 2004
Posts: 1,600
Default Re: Doesn't power on

I actually just learned a few hours ago that the problem was a faulty power cable. He switched them out and everything is dandy.

Thanks for all the suggestions


Greg is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Old Power supply Guide (2008) Ste New Systems | Building and Buying 223 12-12-2009 08:05 PM
POST Troubleshooting Guide SYL\X/3K Hardware Repairs and Troubleshooting 7 03-07-2009 10:24 AM
What To Look For When Buying Computer Components Luke Monitors, Printers and Peripherals 25 01-07-2009 08:09 PM
Power Supply Guide Ste Overclocking and Modding 0 02-18-2008 02:18 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:35 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.