Did I fry my video card? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 02-05-2010, 09:11 AM   #1 (permalink)
Newb Techie
 
Join Date: Feb 2010
Posts: 1
Default Did I fry my video card?

For 1-2 years I'd been gaming on my PC 4 hours/day on weekdays, 8+ hours/day on weekends with no problems. Then last summer I'd been gaming almost 14 hours/day on it, and I started getting weird visual errors kinda like this this while gaming, but I continued playing, then it started freezing while gaming; I assume this was from overheating because the side of the case was hot. Eventually it always had multi-colored dots on the screen, and it would freeze from simpler tasks like web browsing, then it would freeze up sooner and sooner after rebooting. When this happened I had been running Windows XP, so I switched to Ubuntu to see if that would help. I think it ran half decently for a couple days on Ubuntu, it still had the dots on the screen and I couldn't play games or anything but I could browse the web. Then it started freezing again. I turn it on, it has multi-colored dots on the screen, I load up anything such as firefox and it freezes; I can move the mouse cursor but nothing else happens, the clock doesn't update or anything. Did I fry my video card?
__________________

cyetter is offline  
Old 02-05-2010, 12:04 PM   #2 (permalink)
Call me Mak or K
Mod Emeritus
 
KSoD's Avatar
 
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: Did I fry my video card?

It certainly sounds like it. I would get a new one for sure. That artifacting that you are showing is a sure sign of damage to the card.
__________________
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help With New Video Card Hunter434 System Upgrades 11 09-21-2009 06:30 PM
Which video card to go with? Ksingler System Upgrades 4 03-20-2009 07:44 PM
New video card. 35g700 New Systems | Building and Buying 16 03-20-2009 03:45 PM
Possible video card issue -- ATI X1650 houndofspace Hardware Repairs and Troubleshooting 10 12-04-2007 02:17 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:03 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.