Diabling DMA in Windows XP - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 12-14-2005, 09:36 AM   #1 (permalink)
Newb Techie
 
Join Date: Oct 2005
Posts: 39
Default Diabling DMA in Windows XP

In a pc I've recently built I've installed Power dvd however I need to disable the DMA on my dvdrom and dvd -burner. (power dvd gave me the enable/disable options DMA). The options to disable the DMA for these two drives are grayed-out and I'm unable to uncheck them.

With Windows 2k sp4 I had that option. When the dma is turned on I had problems with the computer freezing up whenever playing a movie. I'm now having this proble now that I have Win XP sp2 installed.

The IDE hard discs are DMA enables whih is correct.

Not quite sure how to disable the DMA for these two drive within the regestry but hopefully there's another method to accomplish this. Any suggestions would be appreciated.
__________________

lws_junior is offline  
Old 12-14-2005, 01:11 PM   #2 (permalink)
Master Techie
 
RicoDirenzo's Avatar
 
Join Date: May 2005
Posts: 2,102
Default

To Disable DMA in Windows XP:


1. Log in to Windows with administrator access.

2. Right-click My Computer, and choose Properties.

3. Click the Hardware tab, and then click Device Manager.

4. Unclick the plus sign (+) beside IDE ATA/ATAPI Controllers.

5. Right-click the IDE disk, and choose Properties.

6. Click the Advanced Settings tab, and select DMA if available from the Transfer Mode menu.

7. Click OK when Windows returns an alert about Disabling DMA.

8. In the Device Manager, unclick the plus sign (+) beside DVD/CD-ROM drives.

9. Right-click the DVD drive, and choose Properties. Click the Settings tab, and select Disable DMA. (This option won't appear if the drive isn't connected to the IDE chain.)

10. Repeat step 9 for the CD-ROM drive if it exists.
__________________

__________________
Noli Nothis Permittere Te Terere!!
EVGA 680i, Dual EVGA 8800GT'S (650/950), 4 gigs OCZ DDR2 1066, Intel Q9450 at 3.8 Ghz, Koolance Water Cooled, Dual Plextor16x DL DVD+/-RW. Dual WD 250gb 16mb Cache Sata 3.0. 3DMark06 score = 19,168.
RicoDirenzo is offline  
Old 12-14-2005, 06:44 PM   #3 (permalink)
Newb Techie
 
Join Date: Oct 2005
Posts: 39
Default

Thanks for the reply.


Quote:
Right-click the DVD drive, and choose Properties. Click the Settings tab, and select Disable DMA. (This option won't appear if the drive isn't connected to the IDE chain.)

On this machine there is no Setting tab available to deselect the dma. My dvd-rom and dvd-burner are both on the IDE-secondary channel. I would tend to believe there would be this setting.

Even the Win2k sp4 system I'm on now doesnt have the dma setting for the dvd-rom drive and burner.

The program PowerDVD shows that the dma is off for the two devices and movies play ok in Win2k. In WinXP PowerDVD shows the dma for these two drives are enabled and can't be changed within the program. Movies freeze up when I play them.

This is a new one on me. Any more advise will be appreciated
lws_junior is offline  
Old 12-14-2005, 07:31 PM   #4 (permalink)
Master Techie
 
RicoDirenzo's Avatar
 
Join Date: May 2005
Posts: 2,102
Default

Yikes.........hmmmmmmmm...............Xp and 2000 both defualt to +DMA. I don't quite understand why that program requires that DMA be disabled but I'll do some addtional research and see what I can find out.

Ok, try this:

To disable DMA in Windows 2000 or XP:

Right-click My Computer and select Properties.

Select the Hardware tab when the systems properties window appears.

In the Hardware tab, select the Device Manager button.

Double-click IDE ATA/ATAPI Controllers to expand the options.

Under IDE ATA/ATAPI Controllers, double-click on the listing to bring up the property dialog box for the Primary IDE channel.

Click on the Advanced settings tab.

Note: If you do not have an advanced settings tab, you may have a vendor accelerator software

package installed. Check Start>Programs for “Intel Application Accelerator” or similar program and remove using the “Add/Remove Programs” Control Panel.

If available, set Transfer Mode for Device 0 and 1 to No DMA. Then select OK.

Your computer asks if you would like to reboot at this point. Select NO.

Repeat steps 5–8 for the Secondary IDE channel.

This time, when you are prompted, select Reboot.

DO THIS FOR THE SECONDARY ide CHANNEL ONLY!!!!!!!!!!
__________________
Noli Nothis Permittere Te Terere!!
EVGA 680i, Dual EVGA 8800GT'S (650/950), 4 gigs OCZ DDR2 1066, Intel Q9450 at 3.8 Ghz, Koolance Water Cooled, Dual Plextor16x DL DVD+/-RW. Dual WD 250gb 16mb Cache Sata 3.0. 3DMark06 score = 19,168.
RicoDirenzo is offline  
Old 12-15-2005, 09:42 PM   #5 (permalink)
Wizard Techie
 
Join Date: Apr 2004
Posts: 3,247
Default

Probably have accelerator softare. Go into add remove programs and look for something like 'intel application accelerator' and uninstall it. If you can in here set the Transfer Mode for dev 0 and 1 to No DMA select okay, dont restart and set the others that you need to set. Basically, restart after you have whatever IDE dev set to PIO (guessing) that you need. THEN restart. That should do it, if not then you'll probably need to edit ther registry.
__________________
If you argue with an idiot he will drag you down to his level and beat you with experience.

I am not a fast writer.
I am not a slow writer.
I am a half-fast writer.

-Robert Asprin
killians45 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.