Dell Studio 1909 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-27-2011, 01:29 PM   #1 (permalink)
Newb Techie
 
Join Date: Oct 2011
Location: Baltimore
Posts: 4
Default Dell Studio 1909

Hello! I have a Dell Studio 1909 AIO Touchscreen that I am trying to repair. Problem is, i am stuck. The customer has only had it for a week and everything was fine. Then they said the screen wouldn't come on. They claim not to have changed anything, but when it comes on, the Dell Logo comes up, then the backlight goes out. You can use a flashlight and see that it's still booting. Then, the pointer and "Wait" symbol comes up as normal, then the backlight goes out again once windows is at the login screen. My assumption is a driver issue. Maybe the Vista system updated and cause an issue? Does this sound about right to anyone? And if so, how can i update/rollback the driver on something i can't see enough to work on?

Thanks in advance for any suggestions.
__________________

Amoed77 is offline  
Old 10-27-2011, 02:21 PM   #2 (permalink)
Banned
 
Join Date: Apr 2005
Location: n/a
Posts: 2,956
Default Re: Dell Studio 1909

Quote:
Originally Posted by Amoed77 View Post
Hello! I have a Dell Studio 1909 AIO Touchscreen that I am trying to repair. Problem is, i am stuck. The customer has only had it for a week and everything was fine. Then they said the screen wouldn't come on. They claim not to have changed anything, but when it comes on, the Dell Logo comes up, then the backlight goes out. You can use a flashlight and see that it's still booting. Then, the pointer and "Wait" symbol comes up as normal, then the backlight goes out again once windows is at the login screen. My assumption is a driver issue. Maybe the Vista system updated and cause an issue? Does this sound about right to anyone? And if so, how can i update/rollback the driver on something i can't see enough to work on?

Thanks in advance for any suggestions.
Sounds abit right, try this for me please, reboot the computer and after the bios screen if you can see it, hit F8 until you get into windows safe mode.
Make sure the screen is lit up, if you can login and see their desktop, use system restore to see if you can go back to the customers problem when they were having problems in restore it.

My other thoughts is the monitor itself having problems ? if the screen is pretty dimm and faint, you might want to to fix the inverter inside of it by replacing it.


Read this and get started to see if you can fix it, by the looks of that model it looks like it's pretty trouble some.>_>
Dell One 19 Manuals, Support and Troubleshooting - Studio Desktops
__________________

-RockMan- is offline  
Old 10-28-2011, 01:42 PM   #3 (permalink)
Newb Techie
 
Join Date: Oct 2011
Location: Baltimore
Posts: 4
Default Re: Dell Studio 1909

Thanks for the response. I tried booting into SafeMode, still goes dark on me. So, at this point, it's got to be the inverter. This should be fun
Amoed77 is offline  
Old 11-04-2011, 01:14 PM   #4 (permalink)
Newb Techie
 
Join Date: Oct 2011
Location: Baltimore
Posts: 4
Default Re: Dell Studio 1909

Just wanted to drop a line and say thanks again. The Inverter was replaced and so far, that seems to take care of the problem.
Amoed77 is offline  
Old 11-04-2011, 04:10 PM   #5 (permalink)
Banned
 
Join Date: Apr 2005
Location: n/a
Posts: 2,956
Default Re: Dell Studio 1909

Quote:
Originally Posted by Amoed77 View Post
Just wanted to drop a line and say thanks again. The Inverter was replaced and so far, that seems to take care of the problem.
Not a problem, I'm just glad the repair was simple enough for you to tackle.
Also was that computer under warrenty ? meant to ask you that, sometimes dell does not like you touching their parts when it's underwarrenty.

I personally do not care and fix the computer anway, saving me issues and problems with them.
-RockMan- is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell Studio 1 1909, Touchscreen not being detected mandi42389 Hardware Repairs and Troubleshooting 1 09-18-2011 02:51 PM
studio one 1909 connection to hd tv shezi420 Computer Networking and Internet Hardware 1 03-29-2011 02:45 PM
Dell studio one 1909 techuser3344 Hardware Repairs and Troubleshooting 4 01-08-2011 04:51 AM
dell Studio 15 Deadpixel Laptops and Notebooks 2 07-24-2008 05:38 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.