Dead Motherboard? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 02-17-2009, 07:04 PM   #1 (permalink)
Super Techie
 
Tenenbaum's Avatar
 
Join Date: Jul 2008
Posts: 359
Send a message via MSN to Tenenbaum
Default Dead Motherboard?

All case fans go up, CPU fan goes on, Video card fan goes on, everything stays powered, this motherboard has on-board video, and the video card, neither worked.

The only problem is, I'm getting no output to my monitor, its not the monitor or cables, because they work on another computer.

Any suggestions or comments?

Thanks
__________________

Tenenbaum is offline  
Old 02-17-2009, 07:13 PM   #2 (permalink)
Lady Techie
 
Yami's Avatar
 
Join Date: Dec 2008
Location: UK
Posts: 7,773
Default Re: Dead Motherboard?

Remove all but one stick of RAM, and see if it works. If it doesn't, try a different stick of RAM. If one works, add another.
Basically, just see if you have any bad RAM.
__________________

__________________
Desktop i5-4440 - ASRock Z77 Extreme4 - EVGA GTX970 - 4x4GB 1600MHz - Samsung 850 EVO 250GB - Be Silent Base 800 - 3TB+1TB+1TB+640GB
Laptop i7-3740QM @ 2.7GHz, 2x4GB 1600Mhz, GT640M, OCZ Agility 3 120GB
Smartphone Galaxy S7 Edge

LinkedIn Kiera Mitchell
Yami is offline  
Old 02-17-2009, 07:32 PM   #3 (permalink)
Super Techie
 
Tenenbaum's Avatar
 
Join Date: Jul 2008
Posts: 359
Send a message via MSN to Tenenbaum
Default

I pretty much know the routine, its just, I was seeing if anyone would give a suggestion on something I might miss?
(Its for a friend, he just got a new build, trying to explain over Ventrilo)

I'll let him know to re-seat the ram and try different slots/ram, appreciate it!

LED on motherboard does not come on, nor does it beep.

I'm having him disconnect everything, and then plugging only the power to the motherboard in, to see if the LED goes on.

Any other suggestions?
Tenenbaum is offline  
Old 02-21-2009, 01:48 PM   #4 (permalink)
True Techie
 
Join Date: Jul 2007
Posts: 124
Default Re: Dead Motherboard?

how it turn out for you because I am having the exact same problem...
shenvoid01 is offline  
Old 02-21-2009, 02:26 PM   #5 (permalink)
krazy Techie
 
krazyq's Avatar
 
Join Date: Aug 2006
Location: Minnesota
Posts: 8,059
Default Re: Dead Motherboard?

umm buddy
i just solved this problem with my pc
it was the ram for me...
__________________
Intel Core i5-4670K
ASRock Z97 Anniversary
8 GB G.SKILL Ripjaws
MSI GTX 1070 Gaming X
Sandisk Ultra II 960GB + Samsung 850 EVO 500GB + 2TB + 1TB WD Black
Samsung Note 8
2TB White PS4 Pro, PS3, Switch & New 3DS XL
65" LG OLED C7P
BenQ 27" XL2720Z
krazyq is offline  
Old 02-21-2009, 04:22 PM   #6 (permalink)
Newb Techie
 
Join Date: Feb 2009
Location: New York
Posts: 22
Default Re: Dead Motherboard?

if the LED on the motherboard is not lit then it could possible be a bad power supply. sometimes the PSU will supply just the power to run fans and other things but it might not be working fully to power the computer. You can try a different power supply or get a power supply tester to test the one you have
Ab0mbs is offline  
Old 02-21-2009, 05:34 PM   #7 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,510
Default Re: Dead Motherboard?

Try resetting CMOS as well as above suggestions.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is online now  
Old 02-22-2009, 10:33 PM   #8 (permalink)
Yee Ol' Salt
 
Hampton's Avatar
 
Join Date: Dec 2008
Location: USA
Posts: 642
Default Re: Dead Motherboard?

not sure if this was mentioned yet but pull out all the items.. all ram all PCI, PCI-e.. everything but the PSU.. then boot.. if at that point you get nothing, I suggest try a different PSU and if nothing still then.. it's the board. but if the original PSU lights up with nothing else in, then place one thing at a time back in with booting it each time with every new part added until you find the bad guy.
__________________

Find my post helpful? IF so please rate me by clicking the green check mark under my avatar.





:D Antec 300|M3N72-D|AMD PHM II X3 BE 720 3.0ghz (CodeName "Heka")|OCZ Stealth Xtreme 600w|2 two gig OCZ DDR2 1066 gold 4 GB of Ram|BFG-GTX 260 512||Samsung 42" Plasma| XP x86 sp3 /Vista x386 and x64|
The face I make everytime I'm on my machine :eek:
Hampton is offline  
Old 02-22-2009, 11:29 PM   #9 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,510
Default Re: Dead Motherboard?

A computer won't boot without RAM, Hampton . Would need only the basics: RAM/CPU/Cooler/video/PSU.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is online now  
Old 02-23-2009, 01:22 AM   #10 (permalink)
Yee Ol' Salt
 
Hampton's Avatar
 
Join Date: Dec 2008
Location: USA
Posts: 642
Default Re: Dead Motherboard?

it will post with out ram
He needs to post before he can boot.. right now were trying to figure out why he is not getting post.
__________________

__________________

Find my post helpful? IF so please rate me by clicking the green check mark under my avatar.





:D Antec 300|M3N72-D|AMD PHM II X3 BE 720 3.0ghz (CodeName "Heka")|OCZ Stealth Xtreme 600w|2 two gig OCZ DDR2 1066 gold 4 GB of Ram|BFG-GTX 260 512||Samsung 42" Plasma| XP x86 sp3 /Vista x386 and x64|
The face I make everytime I'm on my machine :eek:
Hampton is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading to a Newer Motherboard - Advice Needed Shyam Bhat New Systems | Building and Buying 6 11-03-2008 10:56 AM
What Motherboard for my High Performance computer???? Jethro69 New Systems | Building and Buying 2 10-27-2008 04:24 PM
PC Build: Which Asus motherboard? (Ordering all parts in 24hours) DJ Redrum New Systems | Building and Buying 7 04-09-2008 05:59 PM
Motherboard Questions & Help Me Find a Mobo Cunjo New Systems | Building and Buying 37 07-13-2007 01:24 AM
Could dead motherboard damage other parts? pinoy3000 New Systems | Building and Buying 3 05-31-2007 10:11 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:19 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.