Curious about why this happened... - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 04-28-2011, 05:13 PM   #1 (permalink)
Super Techie
 
Join Date: Sep 2010
Posts: 345
Default Curious about why this happened...

This isn't really a problem per se, as I've been able to "fix" it, but I'm really interested in understanding the reason behind it.

I recently installed Fallout: New Vegas on my computer. Here is what happened in order:

1. I started FNV, and there was major flickering, to the point that I would consider the game too annoying to play.
2. I changed the overclock in Afterburner back to stock, rebooted, and then used GPU-Z to make sure the clock settings were at stock. I still got flickering.
3. I then set Afterburner to not start with Windows, and restarted. When I started FNV, there was no flickering. I quit, then went into GPU-Z to make sure the settings were still at stock, and not another Afterburner profile, then restarted FNV, and it was back to flickering.

I could go on, but basically it boils down to this: I can overclock or keep it stock, and there is no flickering. However, if I run either GPU-Z or MSI Afterburner, even after they are shut down, FNV will flicker and will not stop flickering unless I reboot my computer.

Just curious what could cause this.
__________________

__________________
Case: Cooler Master HAF X RC-942-KKN1
Power Supply: Silverstone ST1500 1500W
Motherboard: Asus Rampage IV Extreme; CPU: i7-3970; Memory: Corsair Dominator Platinum 32GB @ 2133MHz
Graphics Card: HD7970
Optical: 2 x Lite-On iHAS424SATA 24X DVD
Hard Drive: OCZ RevoDrive 3 X 2 240 GB
Monitor: Samsung 1080P 120Hz 3D
earwicker7 is offline  
Old 04-29-2011, 08:39 PM   #2 (permalink)
Super Techie
 
Join Date: Sep 2010
Posts: 345
Default Re: Curious about why this happened...

Update... it's not just GPU-Z and MSI Afterburner; if I run ANY program before FNV, I get a flickering screen.
__________________

__________________
Case: Cooler Master HAF X RC-942-KKN1
Power Supply: Silverstone ST1500 1500W
Motherboard: Asus Rampage IV Extreme; CPU: i7-3970; Memory: Corsair Dominator Platinum 32GB @ 2133MHz
Graphics Card: HD7970
Optical: 2 x Lite-On iHAS424SATA 24X DVD
Hard Drive: OCZ RevoDrive 3 X 2 240 GB
Monitor: Samsung 1080P 120Hz 3D
earwicker7 is offline  
Old 04-30-2011, 09:31 AM   #3 (permalink)
Lord Techie
 
Slaymate's Avatar
 
Join Date: Feb 2009
Location: Florida
Posts: 7,946
Default Re: Curious about why this happened...

Try a different video driver.
__________________
[SIGPIC][/SIGPIC]
Slaymate is offline  
Old 04-30-2011, 11:50 PM   #4 (permalink)
Super Techie
 
Join Date: Sep 2010
Posts: 345
Default HD5970 Flickering in Full-Screen, Fine in Windowed Mode

I originally thought this was a Fallout New Vegas problem, but when I tried running GPU Tool, it also happened. I am getting flickering screens on both of these programs if they are running in fullscreen, but they are fine when I run in windowed mode. Most of the time, Fallout will run fine in fullscreen if I don't run any programs before it (i.e., I have to reboot if I have run anything else), but even this doesn't happen 100% of the time.

The weird thing is that neither of the Futuremark programs (either DX10 or DX11) has this issue. I think I read somewhere that Fallout uses DX9 tech; is this the case with GPU Tool?

Some odds and ends; last week, I made the mistake of using DriverCleaner, which practically killed my computer (BSOD with any ATI drivers, drivers wouldn't install correctly, etc.). I was ready to do a clean reinstall, but miraculously, through some dumb luck (i.e., I don't know what exactly happened) I managed to get the 11.4 drivers to install. This was right before I started playing Fallout. I went ahead and used DriverSweeper (it's free, and it doesn't kill your computer) and unistalled 11.4, then reinstalled it, and it still is having this issue.

Could this be a Crossfire issue caused by something that was deleted by DriverCleaner? And no, I didn't know about the backup function until after I used it
__________________
Case: Cooler Master HAF X RC-942-KKN1
Power Supply: Silverstone ST1500 1500W
Motherboard: Asus Rampage IV Extreme; CPU: i7-3970; Memory: Corsair Dominator Platinum 32GB @ 2133MHz
Graphics Card: HD7970
Optical: 2 x Lite-On iHAS424SATA 24X DVD
Hard Drive: OCZ RevoDrive 3 X 2 240 GB
Monitor: Samsung 1080P 120Hz 3D
earwicker7 is offline  
Old 05-01-2011, 01:31 AM   #5 (permalink)
Super Techie
 
Join Date: Sep 2010
Posts: 345
Default Re: Curious about why this happened...

As in older drivers? Where is this kind of stuff archived?

By the way, I made a different thread without thinking about this one; you may want to merge them: HD5970 Flickering in Full-Screen, Fine in Windowed Mode
__________________
Case: Cooler Master HAF X RC-942-KKN1
Power Supply: Silverstone ST1500 1500W
Motherboard: Asus Rampage IV Extreme; CPU: i7-3970; Memory: Corsair Dominator Platinum 32GB @ 2133MHz
Graphics Card: HD7970
Optical: 2 x Lite-On iHAS424SATA 24X DVD
Hard Drive: OCZ RevoDrive 3 X 2 240 GB
Monitor: Samsung 1080P 120Hz 3D
earwicker7 is offline  
Old 05-01-2011, 10:06 AM   #6 (permalink)
Lord Techie
 
Slaymate's Avatar
 
Join Date: Feb 2009
Location: Florida
Posts: 7,946
Default Re: Curious about why this happened...

The Vista and Windows 7 drivers are the same

Previous Catalyst
__________________
[SIGPIC][/SIGPIC]
Slaymate is offline  
Old 05-01-2011, 10:48 AM   #7 (permalink)
Super Techie
 
Join Date: Sep 2010
Posts: 345
Default Re: Curious about why this happened...

You may want to check the other thread for this to make sense (the flickering is now occuring on other programs). Did what you said, and no change... by process of elimination, I was able to find out what the problem is; it's Steam. If Steam is in the startup group, it causes GPU Tool to flicker. When I removed from the startup group, the flicker was gone. Now I'm really stumped.
__________________
Case: Cooler Master HAF X RC-942-KKN1
Power Supply: Silverstone ST1500 1500W
Motherboard: Asus Rampage IV Extreme; CPU: i7-3970; Memory: Corsair Dominator Platinum 32GB @ 2133MHz
Graphics Card: HD7970
Optical: 2 x Lite-On iHAS424SATA 24X DVD
Hard Drive: OCZ RevoDrive 3 X 2 240 GB
Monitor: Samsung 1080P 120Hz 3D
earwicker7 is offline  
Old 05-01-2011, 01:55 PM   #8 (permalink)
Lord Techie
 
Slaymate's Avatar
 
Join Date: Feb 2009
Location: Florida
Posts: 7,946
Default Re: Curious about why this happened...

Why did you make two threads for the same problem??
__________________
[SIGPIC][/SIGPIC]
Slaymate is offline  
Old 05-01-2011, 03:16 PM   #9 (permalink)
Super Techie
 
Join Date: Sep 2010
Posts: 345
Default Re: Curious about why this happened...

I know, that's why I asked you if you could merge them.
__________________
Case: Cooler Master HAF X RC-942-KKN1
Power Supply: Silverstone ST1500 1500W
Motherboard: Asus Rampage IV Extreme; CPU: i7-3970; Memory: Corsair Dominator Platinum 32GB @ 2133MHz
Graphics Card: HD7970
Optical: 2 x Lite-On iHAS424SATA 24X DVD
Hard Drive: OCZ RevoDrive 3 X 2 240 GB
Monitor: Samsung 1080P 120Hz 3D
earwicker7 is offline  
Old 05-02-2011, 01:42 PM   #10 (permalink)
Super Techie
 
Join Date: Sep 2010
Posts: 345
Default Re: Curious about why this happened...

Now I'm getting games where the 2D stuff (the user interface) is there, but the 3D parts are missing. I'm just going to do a clean reinstall; all of this started happening right after I used DriverCleaner, so I'm hoping it's a software issue, not a hardware problem (I can still run Futuremark on both DX10 and DX11 with no problems).
__________________

__________________
Case: Cooler Master HAF X RC-942-KKN1
Power Supply: Silverstone ST1500 1500W
Motherboard: Asus Rampage IV Extreme; CPU: i7-3970; Memory: Corsair Dominator Platinum 32GB @ 2133MHz
Graphics Card: HD7970
Optical: 2 x Lite-On iHAS424SATA 24X DVD
Hard Drive: OCZ RevoDrive 3 X 2 240 GB
Monitor: Samsung 1080P 120Hz 3D
earwicker7 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
The most curious AM3 Gothch1ck New Systems | Building and Buying 15 02-11-2009 03:16 PM
Im Just Curious keyser09 Monitors, Printers and Peripherals 5 10-21-2006 03:43 PM
RAM curious. SouthIowa System Upgrades 2 09-13-2005 09:57 PM
just curious ITZBVAN005 Monitors, Printers and Peripherals 1 12-07-2004 09:12 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.