computer won't turn on. HELP! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 05-20-2007, 08:57 AM   #1 (permalink)
True Techie
 
Join Date: Oct 2005
Posts: 160
Default computer won't turn on. HELP!

Hi, This morning I wake up and turn the computer on but nothing happens. My uGuru panel is flashing intermittently and so is the red light on my motherboard. I checked the power connections and they are fine. What do I do? First time I have come across this problem.
__________________

__________________
Case: Silverstone TJ09
CPU: Intel core i7 920 3.6GHz
MOBO: Asus P6TD Deluxe
RAM: 6GB DDR3 1600MHz Corsair Dominator GT
Graphics: 2x Gigabyte GTX 260 Super overclocked
Sound: Asus Xonar D2X
PSU: 850W Corsair
Snake64_009 is offline  
Old 05-20-2007, 09:34 AM   #2 (permalink)
Junior Techie
 
Join Date: Jan 2007
Posts: 60
Send a message via AIM to BryanJK Send a message via MSN to BryanJK Send a message via Yahoo to BryanJK
Default Re: computer won't turn on. HELP!

This is a uGuru panel for those who don't know
If your motherboard led is flashing, the only thing I would think of is power going where its not supposed to. (Pins on motherboard touching metal case? Loose wire touching case? Ect)
__________________

__________________
Intel Pentium 4 - 3.5GHz
3024mb DDR2 778MHz RAM
160gb SATA + 40gb IDE
nVidia GeForce 7600GT (750mhz Core /1200mhz RAM)
Apeva X-Discovery + Blu Orb II + Zalman VGA Cooler
BryanJK is offline  
Old 05-20-2007, 03:53 PM   #3 (permalink)
I know <html>, do you?
 
SYL\X/3K's Avatar
 
Join Date: Aug 2006
Location: 127.0.0.1
Posts: 1,646
Send a message via AIM to SYL\X/3K Send a message via Yahoo to SYL\X/3K
Default Re: computer won't turn on. HELP!

try unplugging the power cord from the PSU for 10 minutes and plug it in and switch the PSU on, if continues to blink then the PSU is faulty or a loose power connection somewhere
__________________
P3 Setup- Intel 1.0ghz , 512Mb SDRAM , ATI 9200 128MB, 2x 40GB HD, Asus CUSL-LV

.....:::::POST Troubleshooting Steps.___.My Rig.___.Memory Test:::::.....
SYL\X/3K is offline  
Old 05-21-2007, 01:56 AM   #4 (permalink)
True Techie
 
Join Date: Oct 2005
Posts: 160
Default Re: computer won't turn on. HELP!

Hi, thanks for the replies. Well I did that sylwek and it stopped flashing BUT nothing comes up on my monitors. What does this mean/what do i do now?
__________________
Case: Silverstone TJ09
CPU: Intel core i7 920 3.6GHz
MOBO: Asus P6TD Deluxe
RAM: 6GB DDR3 1600MHz Corsair Dominator GT
Graphics: 2x Gigabyte GTX 260 Super overclocked
Sound: Asus Xonar D2X
PSU: 850W Corsair
Snake64_009 is offline  
Old 05-22-2007, 01:35 AM   #5 (permalink)
Super Techie
 
Join Date: Sep 2005
Posts: 422
Send a message via AIM to Kubel
Default Re: computer won't turn on. HELP!

Pray that if it's your PSU that it didn't fry everything in your case.
__________________
For I am not ashamed of the gospel of Christ: for it is the power of God unto salvation to every one that believeth
~Romans 1:16
Kubel is offline  
Old 05-22-2007, 07:01 AM   #6 (permalink)
True Techie
 
Join Date: Oct 2005
Posts: 160
Default Re: computer won't turn on. HELP!

well if it did I have it all on waranty lol. So what do i do then? How do i check?
__________________
Case: Silverstone TJ09
CPU: Intel core i7 920 3.6GHz
MOBO: Asus P6TD Deluxe
RAM: 6GB DDR3 1600MHz Corsair Dominator GT
Graphics: 2x Gigabyte GTX 260 Super overclocked
Sound: Asus Xonar D2X
PSU: 850W Corsair
Snake64_009 is offline  
Old 05-22-2007, 08:11 PM   #7 (permalink)
True Techie
 
Join Date: Oct 2005
Posts: 160
Default Re: computer won't turn on. HELP!

nobody any ideas?
__________________
Case: Silverstone TJ09
CPU: Intel core i7 920 3.6GHz
MOBO: Asus P6TD Deluxe
RAM: 6GB DDR3 1600MHz Corsair Dominator GT
Graphics: 2x Gigabyte GTX 260 Super overclocked
Sound: Asus Xonar D2X
PSU: 850W Corsair
Snake64_009 is offline  
Old 05-24-2007, 03:33 PM   #8 (permalink)
Junior Techie
 
Join Date: Jan 2007
Posts: 60
Send a message via AIM to BryanJK Send a message via MSN to BryanJK Send a message via Yahoo to BryanJK
Default Re: computer won't turn on. HELP!

Find a working power supply, other than the one your using now... and hook all the parts up. Read up on your Warranty though, don't void it.
__________________
Intel Pentium 4 - 3.5GHz
3024mb DDR2 778MHz RAM
160gb SATA + 40gb IDE
nVidia GeForce 7600GT (750mhz Core /1200mhz RAM)
Apeva X-Discovery + Blu Orb II + Zalman VGA Cooler
BryanJK is offline  
Old 05-24-2007, 04:02 PM   #9 (permalink)
Everything to Nothing
 
Nick's Avatar
 
Join Date: Feb 2007
Location: Wales
Posts: 4,053
Send a message via MSN to Nick
Default Re: computer won't turn on. HELP!

what about the front panel connectors?
__________________

Nick is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!!! I disabled my graphics card by accident, need help!! Wildside Monitors, Printers and Peripherals 5 06-16-2007 07:29 PM
computer freezes/beeps forever cullensmi Hardware Repairs and Troubleshooting 1 05-12-2007 12:40 PM
Computer won't turn on tzvii Hardware Repairs and Troubleshooting 18 04-18-2007 01:07 AM
my computer will not turn on beer-b-q Hardware Repairs and Troubleshooting 3 04-15-2007 09:29 PM
New Computer. Same Issues Duality Hardware Repairs and Troubleshooting 6 04-01-2007 10:54 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:37 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.