Computer wont turn on - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 08-31-2006, 02:28 PM   #1 (permalink)
Junior Techie
 
Join Date: Aug 2006
Posts: 63
Default Computer wont turn on

Hello everyone I just built my first computer and connected every wire to its slot now my problem is I cant seem to get the bloody thing to start as it wont turn on at all when i press the power switch so i am not really sure what the problem is but to help you guys help me here is specifications.

Cooler Master case http://www.newegg.com/Product/Produc...82E16811119068

Rosewill power supply
http://www.newegg.com/Product/Produc...82E16817182043

Foxconn mobo
http://www.newegg.com/Product/Produc...82E16813186059

Amd Athlon 64 X2 4400+
http://www.newegg.com/Product/Produc...82E16819103626
__________________

__________________
Let\'s try that again, shall we?
solid102 is offline  
Old 08-31-2006, 02:31 PM   #2 (permalink)
S e c u r e d
 
Join Date: Feb 2005
Location: Somewhere Sunny
Posts: 3,760
Default

Plug it in...



LMAO I Kill me...





ok seriously, check the powersupply connection and all MOBO connections... You may need to start with just the essentials and then try powering on.


please make sure you have checked the power switch in the back (if you have one)...


Report back
__________________

__________________
brady is offline  
Old 08-31-2006, 02:34 PM   #3 (permalink)
Junior Techie
 
Join Date: Aug 2006
Posts: 63
Default

I did man everything is connected and the swtich is on but what do you mean i need to start with the essentials.
__________________
Let\'s try that again, shall we?
solid102 is offline  
Old 08-31-2006, 02:38 PM   #4 (permalink)
S e c u r e d
 
Join Date: Feb 2005
Location: Somewhere Sunny
Posts: 3,760
Default

ex: 1 stick of RAM (if you have 2) ... basically nothing "Extra" that the machine wouldn't need to "Boot".


Sounds like a psu issue so far... Do you hear anything at all? Any fans spinning or ANY power cycle at all?


Try another plug / socket / surge protector...
__________________
brady is offline  
Old 08-31-2006, 02:40 PM   #5 (permalink)
Junior Techie
 
Join Date: Aug 2006
Posts: 63
Default

The psu is working fine it turns one blue light and all and makes sound showing it works.

You seem to be confused what i am saying the pc wont turn on at all no power streaming threw it no boot nothing zip nada.
__________________
Let\'s try that again, shall we?
solid102 is offline  
Old 08-31-2006, 02:43 PM   #6 (permalink)
S e c u r e d
 
Join Date: Feb 2005
Location: Somewhere Sunny
Posts: 3,760
Default

Unplug each thing one at a time and try powering on again...

Example : Unplug HDD and hit the power button...

Do this until you see what is stopping the post.
__________________
brady is offline  
Old 08-31-2006, 02:43 PM   #7 (permalink)
Junior Techie
 
Join Date: Aug 2006
Posts: 63
Default

I suspect its a problem with the frontal panel connection but i connected it like i was told in the manual
__________________
Let\'s try that again, shall we?
solid102 is offline  
Old 08-31-2006, 02:45 PM   #8 (permalink)
S e c u r e d
 
Join Date: Feb 2005
Location: Somewhere Sunny
Posts: 3,760
Default

which connection are you talking about? Front panel... like a usb connection? please explain in detail or take picture for me
__________________
brady is offline  
Old 08-31-2006, 02:48 PM   #9 (permalink)
Junior Techie
 
Join Date: Aug 2006
Posts: 63
Default

I mean the wires you use to connect the mother board to the switch that turns on your computer when you press it.
__________________
Let\'s try that again, shall we?
solid102 is offline  
Old 08-31-2006, 02:54 PM   #10 (permalink)
S e c u r e d
 
Join Date: Feb 2005
Location: Somewhere Sunny
Posts: 3,760
Default

Does it feel loose at all?
__________________

__________________
brady is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.