Computer Turns On but No Display - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Reply
 
Thread Tools Display Modes
 
Old 06-25-2012, 05:50 PM   #1 (permalink)
Super Techie
 
Talyor's Avatar
 
Join Date: Nov 2011
Posts: 336
Default Computer Turns On but No Display

Alright so i recently took out everything of my system and put it back togather but now it doesnt have any display. I have Gigabyte m68mt-s2 motherboard GIGABYTE - Motherboard - Socket AM3 - GA-M68MT-S2 (rev. 1.3) and a AMD Radeon 6670 Newegg.com - GIGABYTE GV-R667D3-1GI Radeon HD 6670 1GB 128-bit DDR3 PCI Express 2.1 x16 HDCP Ready Video Card

The build turns on with all the fans going and even the graphics card fan going but nothing goes on the display. For the motherboard graphics i can't find out how to turn them on since i cant see the motherboard bios so you guys have any ideas for me to try to get the motherboard graphics on and to see if its just the graphics card?
__________________

Talyor is offline   Reply With Quote
Old 06-25-2012, 07:13 PM   #2 (permalink)
The Ghost
 
luke127's Avatar
 
Join Date: Mar 2012
Location: Australia
Posts: 838
Default Re: Computer Turns On but No Display

Can I just ask why are there 2 threads with the same name with the same stuff?? K could you or another mod please move this to Monitors, Printers and Peripherals? As it involves a screen issue.
OP: What kind of connection are you using? VGA HDMI or something else? Also have you tried checking the BIOS for any issues?
__________________

__________________
Yeah, I'm the boss 😂😂 FIGJAM 😂😂
luke127 is offline   Reply With Quote
Old 06-25-2012, 07:21 PM   #3 (permalink)
Wizard Techie
 
Join Date: May 2011
Posts: 3,077
Default Re: Computer Turns On but No Display

the motherboard has on board video, did you connect you monitor to the video ports to the gigabyte video card or the on board video port?
Joe C is offline   Reply With Quote
Old 06-25-2012, 07:29 PM   #4 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,510
Default Re: Computer Turns On but No Display

Since you said you took everything out of your system.. triple check all connections (power connectors, PCI cards, graphics card, RAM, etc.). Make sure it's all tight / secured in. RAM could be the most common one, as everything will appear to run fine, but no video will come up on screen if one of the RAM modules isn't in tightly. I've done this several times myself.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is online now   Reply With Quote
Old 06-25-2012, 07:50 PM   #5 (permalink)
Junior Techie
 
Join Date: Jun 2012
Posts: 63
Default Re: Computer Turns On but No Display

Can you see bios post or no?
mac_attack is offline   Reply With Quote
Old 06-25-2012, 08:00 PM   #6 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,510
Default Re: Computer Turns On but No Display

He stated in his first post he can't see BIOS.
__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is online now   Reply With Quote
Old 06-25-2012, 09:10 PM   #7 (permalink)
Banned
 
Join Date: Apr 2005
Location: n/a
Posts: 2,956
Default Re: Computer Turns On but No Display

Quote:
Originally Posted by Talyor View Post
Alright so i recently took out everything of my system and put it back togather but now it doesnt have any display. I have Gigabyte m68mt-s2 motherboard GIGABYTE - Motherboard - Socket AM3 - GA-M68MT-S2 (rev. 1.3) and a AMD Radeon 6670 Newegg.com - GIGABYTE GV-R667D3-1GI Radeon HD 6670 1GB 128-bit DDR3 PCI Express 2.1 x16 HDCP Ready Video Card

The build turns on with all the fans going and even the graphics card fan going but nothing goes on the display. For the motherboard graphics i can't find out how to turn them on since i cant see the motherboard bios so you guys have any ideas for me to try to get the motherboard graphics on and to see if its just the graphics card?
You could try this out, with your card removed and 1 stick of ram, try to reset your motherboard.
clear out the cmos, by moving the jumper for 30 seconds, put it back in, unplug the cord, so the power will discharge out of your board.
Come back in about 2-3 minutes, plug in your cord, hit the on switch on the psu.
If you noticed it powers on without signaling on the motherboard with a green led light something maybe up.
If not, turn on your computer, plug in a good ps2 keyboard, if all goes well, you should see your bios screen!
Next, go to the menu in your bios that says graphic and put it on pci 1 or pci-e slot.
Save in bios, turn off your machine and put back the card, make sure the screw is in but not to tight, that may stop your card from posting up correctly.

Happens with me sometimes, so be patient and try to get it to post up.
-RockMan- is offline   Reply With Quote
Old 06-26-2012, 10:52 PM   #8 (permalink)
Super Techie
 
Talyor's Avatar
 
Join Date: Nov 2011
Posts: 336
Default Re: Computer Turns On but No Display

Wheres the jumper exactly and I never seen led lights on my motherboard even when the computer was working
Quote:
Originally Posted by Mike-Techno-Thug View Post
You could try this out, with your card removed and 1 stick of ram, try to reset your motherboard.
clear out the cmos, by moving the jumper for 30 seconds, put it back in, unplug the cord, so the power will discharge out of your board.
Come back in about 2-3 minutes, plug in your cord, hit the on switch on the psu.
If you noticed it powers on without signaling on the motherboard with a green led light something maybe up.
If not, turn on your computer, plug in a good ps2 keyboard, if all goes well, you should see your bios screen!
Next, go to the menu in your bios that says graphic and put it on pci 1 or pci-e slot.
Save in bios, turn off your machine and put back the card, make sure the screw is in but not to tight, that may stop your card from posting up correctly.

Happens with me sometimes, so be patient and try to get it to post up.
Talyor is offline   Reply With Quote
Old 06-27-2012, 02:46 AM   #9 (permalink)
The Ghost
 
luke127's Avatar
 
Join Date: Mar 2012
Location: Australia
Posts: 838
Default Re: Computer Turns On but No Display

Quote:
Originally Posted by Talyor View Post
Wheres the jumper exactly and I never seen led lights on my motherboard even when the computer was working
I haven't seen any lights on a MB either.
__________________
Yeah, I'm the boss 😂😂 FIGJAM 😂😂
luke127 is offline   Reply With Quote
Old 06-27-2012, 11:43 AM   #10 (permalink)
Private Joker
 
carnageX's Avatar
 
Join Date: Feb 2007
Location: South Dakota
Posts: 24,510
Default Re: Computer Turns On but No Display

Not all boards have lights on them - it's a manufacturer thing, usually.

Have you checked all of your connections to make sure everything is secured?

Also, try resetting your BIOS settings to default. Do this by unplugging the computer from the wall, press the power button a few times to discharge any remaining power, and then remove the silver coin battery on the motherboard. Leave it out for a few minutes, and then place it back in, and plug your computer back in. Try turning the computer on and see if it gets to POST now.

You can also clear BIOS by putting a jumper on the CMOS_CLR pins for a few seconds (with the computer off). Check your motherboard manual to find out where these are located for sure.
__________________

__________________
Laptop: MSI GT70 2OC-059us | i7-4700MQ | 16GB | GTX 770m | 500GB SSD / 750GB HDD | 17.3" | Win10 Pro
Desktop: 4690k | 12GB g.Skill RipJaws | GTX 970 | 520hx | Z87X-UD4H | Corsair Vengeance C70 | Corsair H110 | Acer 25" | Acer 22" | Win10
Mobile: Samsung Galaxy Note 5


If I help you, or you just like what I said, rep me by clicking the under my post
carnageX is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer Turns on, GPU Fan Turns on, No Video smalls0224 Hardware Repairs and Troubleshooting 0 05-13-2008 11:11 AM
HELP! Desktop turns on and restarts repeatedly, other turns on to black screen cvocvo Hardware Repairs and Troubleshooting 1 12-31-2007 01:21 AM
Computer Turns Off? oliminator Hardware Repairs and Troubleshooting 2 03-26-2007 05:31 PM
Computer turns on but nothing happens uKiE Hardware Repairs and Troubleshooting 3 07-24-2006 11:17 PM
Computer turns self off tammy1999 Hardware Repairs and Troubleshooting 2 10-02-2005 07:38 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.