Computer problems - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 07-11-2010, 08:20 PM   #11 (permalink)
Newb Techie
 
Join Date: Jul 2010
Posts: 7
Default Re: Computer problems

I ordered a Nvidia EVGA GTX 470, hopefully That fixes it. I think its the graphics card. If this doesn't work, I will be back on the forum thanks for your help
__________________

frankdur is offline  
Old 07-12-2010, 11:05 PM   #12 (permalink)
Newb Techie
 
Join Date: Jul 2010
Posts: 7
Default Re: Computer problems

Gaaah I got red pixels on my left screen, so yea I think this graphics card is dieing, would anything else cause this?
__________________

frankdur is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
un necessary loading times for my computer darklordofspawn Hardware Repairs and Troubleshooting 0 01-08-2010 10:42 PM
Having problems connecting Computer / Computer. gilbebd04 Computer Networking and Internet Hardware 1 06-18-2009 06:45 PM
A Computer Building Guide.....by Elbatrop1 Elbatrop1 System Upgrades 31 04-07-2007 08:26 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.