comp wont turn on - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 01-02-2007, 01:37 AM   #1 (permalink)
Newb Techie
Join Date: Nov 2005
Posts: 7
Send a message via AIM to the ryan
Angry comp wont turn on

hey everyone,

i was in the middle of playing a game just like ten minutes ago....and my comp just froze. so i restarted it and it turned off, and doesnt turn back on. It will turn as far as loading up the drives and fans but then shut off before a picture of anything actually appears on the screen.

from what ive been reading it's probably my power supply or motherboard, but more likely power supply i think.

so the main problem is it wont even turn on now, but i have had problems in the past where it randomly wasnt too often, only when i had a lot running and at that only about once every other day.

ive talked to my friend about that who works with comptuers more than me and he also suggested that it was the power supply, becuase im running a lot in my computer.

specs are -
amd dual core 4600+ windsor if i remember right
320 GB WD hard drive
ASUS M2N-E mobo
radeon x1800xt 256 mb
zs audigy 2 gamer
corsair xms ram DDR2 800 (PC4400)
and one dvd rw drive

i think thats it that i can remember.

thanks everyone.

the ryan is offline  
Old 01-02-2007, 05:00 PM   #2 (permalink)
Monster Techie
MrCoffee's Avatar
Join Date: Feb 2006
Location: UK
Posts: 1,858

sounds like a PSU problem as you say. Is the fan in the PSu spinning ok when you turn it on?

Intel core I7 920
6GB OCZ platinum 1600
XFX HD4890
Noctua nh-u12p
Corsair HX520
Antec 300
Samsung 1TB F1 Spinpoint
Samsung SM2443BW 24"
MrCoffee is offline  
Old 01-02-2007, 06:50 PM   #3 (permalink)
Newb Techie
Join Date: Nov 2005
Posts: 7
Send a message via AIM to the ryan

hey i just checked it, and no the fan isnt spinning

this sucks cuz i just bought this like 4 months ago

solution = go buy a new one??
the ryan is offline  
Old 01-02-2007, 07:05 PM   #4 (permalink)
I know <html>, do you?
SYL\X/3K's Avatar
Join Date: Aug 2006
Posts: 1,646
Send a message via AIM to SYL\X/3K Send a message via Yahoo to SYL\X/3K

just for future notice, clean out ur fans every couple months due to dust (& ur heatsink),sounds like its dead time for a new one
P3 Setup- Intel 1.0ghz , 512Mb SDRAM , ATI 9200 128MB, 2x 40GB HD, Asus CUSL-LV

.....:::::POST Troubleshooting Steps.___.My Rig.___.Memory Test:::::.....
SYL\X/3K is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:14 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.