cd-rom drive not working, help! - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 01-16-2006, 05:06 AM   #1 (permalink)
Newb Techie
Join Date: Jan 2006
Posts: 6
Default cd-rom drive not working, help!

hello, my cd-rom rw drive is not working anymore. it still shows up as installed in my computer, and in the device manager. and it says its working properly. and when i put in any kind of cd, it takes 5 minutes just reading it and when it is done, it says there's no disc. and when i take the disc back out, and just push the eject button to slide the empty tray back in, it takes 5 minutes to settle down. when i mean settle down, the "read" light starts blinking for five minutes and you can't open up the cd drive folder, until it's done. this started happening as i was playing a game, and then it started to make weird sounds so then i stopped the program and took out the cd. and then it started to get messed up. the game cd is kinda scratched a lot but it worked fine before when i used to play it a lot in the same condition. is there a way to fix this?

psychojoshie is offline  
Old 01-16-2006, 09:22 AM   #2 (permalink)
Lord Techie
Nitestick's Avatar
Join Date: May 2005
Location: смерти для спаме
Posts: 8,473

does it only do this with that one disc? if not sounds like a dead drive.

Visit my website -
"Guitar is cool. If you donít think the guitar is cool, then youíre stupid. And I will fight you! " - Brendon Small
I'm sorry but I do not accept support requests via IM, email, or personal messages
You can contact me for Forum related issues via PM only.

Nitestick is offline  
Old 01-16-2006, 11:38 AM   #3 (permalink)
Newb Techie
Join Date: Jan 2006
Posts: 6

well i dont think its a dead drive because everything is still working properly, if it was malfunctioning, then it would say it. but i think the problem is just with the reading. do you think maybe the lens that reads the cd is faulty?
psychojoshie is offline  
Old 01-16-2006, 02:25 PM   #4 (permalink)
Newb Techie
Join Date: Dec 2005
Posts: 29

disable it and reenable it. a little refreshment usually fixes everything.
Illnab1024 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:39 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.