Catalyst 8.10 Drivers... anyone else tried them?? - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 10-24-2008, 12:30 AM   #1 (permalink)
Electical Engineer
 
BongWizard's Avatar
 
Join Date: Oct 2008
Location: OZ
Posts: 916
Send a message via AIM to BongWizard Send a message via Yahoo to BongWizard
Default Catalyst 8.10 Drivers... anyone else tried them??

i just installed the latest release of the catalyst 8.10 drivers hoping to get a few more frames in Crysis and some decent FarCry2 support and i'm having a pretty chronic problem...

First, i installed them from the standard 3 in 1 package and then i reboot and the res won't go above 640x480x4... so i restart and then as soon as i get past the welcome screen in wondows (ie as soon as the driver should be kicking in) the whole thing goes to sh*te! my whole rig just freezes up and i get some crazy oscillating static-type noise and it doesnt go anywhere... so i reboot, try again, same thing

then i got the 3 separate installers (figured maybe it was just some stupid tech at ATI couldn't compile an installer right) and installed each component separately (after uninstalling the original 8.10 pack), restarting between each component... restart... same issue straight off the bat...

I've gone back to the 8.9 drivers now, but im really just wondering if anyone else has/had the same problem or knows any way around it. (and, no, i dont really wanna hear "Get a GTX 260 Core 216... nv hasnt got any problems" lol)

EDIT: OK... now its doing a similar thing with the 8.9 drivers... except there's no crazy noise and it doesn't totally freeze... when the driver should kick in, the screen just goes black and the fans go absolutely nuts
__________________

__________________

NZXT Lexa BlackLine w/ Red LEDs | Corsair TX-750 | Gigabyte EP45-DS3P | Intel Core 2 Quad Q9300 @ 3.6GHz
2x 2GB Kingston HyperX PC2-6400 @ 960MHz (5-4-4-13) | 3x Seagate Barracuda 7200.11 500GB HDD in RAID5
2x HIS Radeon HD 4850 @ 761/1129 in CrossFireX w/ Thermaltake DuOrbs | Creative X-Fi XtremeGamer Fatal1ty Pro



Got a problem?? Click Here before posting!

BongWizard is offline  
Old 10-24-2008, 01:31 AM   #2 (permalink)
Hard Gay Nahalem! Fooo!
 
NosBoost300's Avatar
 
Join Date: Nov 2005
Location: Bellflower, CA
Posts: 10,154
Send a message via AIM to NosBoost300
Default Re: Catalyst 8.10 Drivers... anyone else tried them??

are you using windows vista?
__________________

__________________
Current Build:
Intel 3770k @ 4.4 GHZ | Galaxy GTX 770 SLi | 16 GB G.Skill Sniper | ASrock z77 Extreme4
2xSamung 840pro 128GB in Raid | 2x1TB Seagate | Antec 750 Watt GamerSeries
Media Build:
Intel Core i3 3220 | Galaxy GTX 650 | 8 GB Corsair Vengeance | ASrock B75M | Samsung 840 120GB
NosBoost300 is offline  
Old 10-24-2008, 06:34 AM   #3 (permalink)
Electical Engineer
 
BongWizard's Avatar
 
Join Date: Oct 2008
Location: OZ
Posts: 916
Send a message via AIM to BongWizard Send a message via Yahoo to BongWizard
Default Re: Catalyst 8.10 Drivers... anyone else tried them??

i was originally using XP... figured it was about time to upgrade so i could use all my memory... installed 8.10 on Vista x64 and got the same kinda issue... except no crazy noise

EDIT: im just gettin the old drivers (8.8/8.9) now
__________________

NZXT Lexa BlackLine w/ Red LEDs | Corsair TX-750 | Gigabyte EP45-DS3P | Intel Core 2 Quad Q9300 @ 3.6GHz
2x 2GB Kingston HyperX PC2-6400 @ 960MHz (5-4-4-13) | 3x Seagate Barracuda 7200.11 500GB HDD in RAID5
2x HIS Radeon HD 4850 @ 761/1129 in CrossFireX w/ Thermaltake DuOrbs | Creative X-Fi XtremeGamer Fatal1ty Pro



Got a problem?? Click Here before posting!

BongWizard is offline  
Old 10-24-2008, 01:27 PM   #4 (permalink)
Hard Gay Nahalem! Fooo!
 
NosBoost300's Avatar
 
Join Date: Nov 2005
Location: Bellflower, CA
Posts: 10,154
Send a message via AIM to NosBoost300
Default Re: Catalyst 8.10 Drivers... anyone else tried them??

did older drivers fix anything... i too had problems with drivers 8.10 when i was using my old 4850's
__________________
Current Build:
Intel 3770k @ 4.4 GHZ | Galaxy GTX 770 SLi | 16 GB G.Skill Sniper | ASrock z77 Extreme4
2xSamung 840pro 128GB in Raid | 2x1TB Seagate | Antec 750 Watt GamerSeries
Media Build:
Intel Core i3 3220 | Galaxy GTX 650 | 8 GB Corsair Vengeance | ASrock B75M | Samsung 840 120GB
NosBoost300 is offline  
Old 10-25-2008, 11:51 PM   #5 (permalink)
Electical Engineer
 
BongWizard's Avatar
 
Join Date: Oct 2008
Location: OZ
Posts: 916
Send a message via AIM to BongWizard Send a message via Yahoo to BongWizard
Default Re: Catalyst 8.10 Drivers... anyone else tried them??

8.9 drivers are working fine for me under Vista x64... but im really keen to figure out this issue so i can get so sweet fps in FC2... its got lame *** CF support right now, but even with 8.10 i dont think its much better
__________________

NZXT Lexa BlackLine w/ Red LEDs | Corsair TX-750 | Gigabyte EP45-DS3P | Intel Core 2 Quad Q9300 @ 3.6GHz
2x 2GB Kingston HyperX PC2-6400 @ 960MHz (5-4-4-13) | 3x Seagate Barracuda 7200.11 500GB HDD in RAID5
2x HIS Radeon HD 4850 @ 761/1129 in CrossFireX w/ Thermaltake DuOrbs | Creative X-Fi XtremeGamer Fatal1ty Pro



Got a problem?? Click Here before posting!

BongWizard is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Catalyst 8.10 Final Drivers gurusan Monitors, Printers and Peripherals 4 10-11-2008 01:04 PM
Catalyst 8.6 Drivers OUT! gurusan New Technology and Products 4 06-19-2008 04:09 PM
"Shoot Em Up" Catalyst drivers on the way Trotter New Systems | Building and Buying 7 10-12-2007 07:26 AM
Leaked ATI Catalyst 7.10 Beta Drivers Osiris Overclocking and Modding 0 09-23-2007 11:35 AM
Catalyst 7.8 Drivers Osiris Overclocking and Modding 0 08-13-2007 07:08 PM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:14 PM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.