Black screen after BIOS initialize - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 08-04-2010, 07:11 PM   #1 (permalink)
Ultra Techie
Join Date: Feb 2006
Location: Auckland, New Zealand
Posts: 905
Default Black screen after BIOS initialize

Yesterday there was a Windows XP update asking me to restart to install it. I just kept hitting restart later so I continue on with what I was doing. After coming back in the morning I found that my computer would start up, go past the mobo startup screen, but then after that and a screen showing some of the computer configuration, PCI configs and such, the screen just goes black instead of showing Windows loading.

Now I had a few power surges a couple months ago where this happened to me then. I was able to fix it by starting in Safe Mode, then just restarting. However when I try to start in SM now it just freezes after listing some Windows drivers.

I've tried using the Windows repair off the install CD but it just passes that initial blue initiaiting screen of the installer then black screens again. I don't think it's my RAM, but I couldn't be sure as I just tried running with one of my two sticks in, testing either one, with the same result. I'm guessing at this point it's either my PSU or my HDD, but I don't know how I can be sure.

If it's any help, I'm currently running a 550W PSU with a Radeon 4870 1GB, so I was thinking perhaps something dodgy is happening with my power supply and it's not powering my card properly to display anything? Currently away from home but planning on testing the machine with a different video card tonight, just wanting to see if anyone else has had a problem similar to this at all.

cyrax is offline  
Old 08-04-2010, 08:08 PM   #2 (permalink)
Newb Techie
Join Date: Aug 2010
Posts: 2
Default Re: Black screen after BIOS initialize

I had a similar problem. We had a power surge due to a lightning hit nearby. After replacing graphics card, updating drivers and generally messing around inside the box I finally replaced the PSU. Since then everything works OK. Try testing the PSU
townplanner is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Computer starts but screen goes black. meb105 Hardware Repairs and Troubleshooting 4 04-05-2010 08:28 AM
No picture on screen after updating BIOS! braz Hardware Repairs and Troubleshooting 4 09-06-2008 04:49 PM
computer shuts down to black no signal screen boxguy2 Hardware Repairs and Troubleshooting 2 02-07-2008 12:19 PM
Screen stays black.... Cajete Hardware Repairs and Troubleshooting 2 04-01-2007 07:20 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:31 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.