ATI Radeon X1950XT - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 04-30-2007, 06:27 AM   #11 (permalink)
Junior Techie
Join Date: Apr 2007
Posts: 63
Default Re: ATI Radeon X1950XT

Here we go then, Managed all and evry download possible over weekend and then tried GTR2 again. It runs in Low/Med detail then crashes again in High detail, BUT it runs now which it wasn't earlier.

NOW the question is, is it struggling to run High now with everything set to basic in CCC i.e. No Overdrive done so still running 500/543 Mem/Clock on Gcard and the 6800GT runs Just above these at 583/602 and this can't managed High detail either but doesn't crash, it just runs at FPS 10-14.

Comparing FPS between cards at Low/Med detail then there isn't much Diff + 6-8FPS. So to me it looks like turning everything up (One at a Time) on the CCC settings could be the way to go and then keep at Med detail and compare FPS to 6800GT Card. Would be annoyied if I've spent all this money on a rocking card to have No such Improvement.

The PSU is a Hiper 580Watt with Lots of Power as People are saying they run 370Watt to run in the Shop Forum (I don't Think so, Blew my 600Watt). It's also been suggested by a number of People to get a Major Brand PSU instead of the one that came with Box, which was Genric. Old PSU had 28Amps(One Rail) BUT new one has 18-20Amps on each rail.

Thxs for all the time,

Shaundale is offline  
Old 05-02-2007, 04:17 AM   #12 (permalink)
Junior Techie
Join Date: Apr 2007
Posts: 63
Default Re: ATI Radeon X1950XT

Well, That didn't go according to plan!
I went into CCC and turned on the Overdrive. Ran the programe to find the best settings for the Clocks and it keeps hanging?
Then reinstalled the 7.4 driver after uninstalling so that the Overdrive was back to normal. Even though the programme hung it changed the clock speeds. Hence the need to reinstall as NOTHING worked after the Overdrive was enabled.

Now that I have started again from scratch I went back to GTR2 and ran at Med detail and the game crashed again, then tried LOW detail and guess what, IT CRASHED!!!!!

Does this point to a knackered Card????


Shaundale is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hrrm I wonder...if an X1950XT will have enough power Sora New Systems | Building and Buying 9 07-17-2007 09:05 PM
Resolution stuck in 1024x768 after install Radeon drivers.. mack Microsoft Windows and Software 6 04-14-2007 11:03 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:58 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.