ATI drivers not found, Radeon HD 5850 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 09-27-2011, 10:29 AM   #1 (permalink)
Junior Techie
Join Date: Jun 2009
Posts: 40
Question ATI drivers not found, Radeon HD 5850

I logged on to Lord of the Rings Online last night after the expansion dropped about 7:30 and started gaming with a buddy. About 10m into playing, I tried to mine a ore node and crashed, about 30m later I went to roll on lootz from a mob and crashed, 20m later I went to click on a dead mob to loot and crashed.

These crashes had a box that came up and said "Your client has stopped responding, close client" and the game screen looked to have a thin layer of white spray paint look all over it.

Another buddy said after the fact that these crashes might have something to do with unupdated plugins to the game I was using, so that may or may not have anything to do with the GPU issue...

My buddy I was gaming with suggested updating my drivers and so when he went AFK, I went to the AMD site and tried to update my driver with this driver suite that came out about a month ago.

The Suite is called "Catalyst Software Suite" and includes:
Display Driver
OpenCL Driver
ATI Integrated Driver
Catalyst Control Center

About 50% into the install, I got the blue screen of death and computer crashed and rebooted with 800x600 resolution telling me that ATI drivers are not detected and I either need to find them or install them...

I still have the driver disc from the GPU box but my disc drive isnt working either, so I plan on fixing that tonight when I get off work, popping in the disc and see if that works, if not then I have until 5pm PST to call tech support and see what they think.

Here is my build (everything a year old):

Case: - COOLER MASTER Storm Scout SGC-2000-KKN1-GP Black Steel / Plastic ATX Mid Tower Computer Case

GPU: - XFX HD-585X-ZAFC Radeon HD 5850 1GB 256-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Video Card w/ Eyefinity

Power Supply: - CORSAIR Professional Series HX750 (CMPSU-750HX) 750W ATX12V 2.3 / EPS12V 2.91 SLI Ready CrossFire Ready 80 PLUS SILVER Certified Modular Active PFC Power Supply

MOBO: - ASUS M4A87TD EVO AM3 AMD 870 SATA 6Gb/s USB 3.0 ATX AMD Motherboard

Processor: - AMD Phenom II X4 955 Black Edition Deneb 3.2GHz 4 x 512KB L2 Cache 6MB L3 Cache Socket AM3 125W Quad-Core Processor HDZ955FBGMBOX

Processor Cooling Thingy: - XIGMATEK HDT-S963 92mm Rifle CPU Cooler I5 775 AMD compatible

Disc Drive: - SAMSUNG 22X Half-Height DVD Writer 22X DVD+R 8X DVD+RW 16X DVD+R DL 22X DVD-R 6X DVD-RW 16X DVD-ROM 48X CD-R 32X CD-RW 48X CD-ROM Black SATA Model SH-S223L LightScribe Support - CD / DVD Burners

HDD: - Western Digital Caviar Black WD7501AALS 750GB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5" Hard Drive -Bare Drive

SSD: - OCZ Agility Series OCZSSD2-1AGT60G 2.5" 60GB SATA II MLC Internal Solid State Drive (SSD)

RAM (8GB): - G.SKILL Ripjaws Series 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model F3-12800CL9D-4GBRL

Monitor: - ASUS VH236H Black 23" 2ms Full HD Widescreen LCD Monitor w/ Speakers 300 cd/m2 20000 :1 (ASCR)

If there are any questions, let me know.

Thanks in advance for the help.

SCHawks73 is offline  
Old 09-28-2011, 12:37 AM   #2 (permalink)
The Grinch
c0rr0sive's Avatar
Join Date: Feb 2005
Location: asdf
Posts: 8,688
Default Re: ATI drivers not found, Radeon HD 5850

Well, it would be nice to know the error code for the BSOD. Download the absolute latest drivers from, and uninstall the old ones while under safemode, reboot, and install the new ones, and reboot again.

c0rr0sive is offline  
Old 09-28-2011, 07:26 AM   #3 (permalink)
Junior Techie
Join Date: Jun 2009
Posts: 40
Default Re: ATI drivers not found, Radeon HD 5850

Originally Posted by c0rr0sive View Post
Well, it would be nice to know the error code for the BSOD. Download the absolute latest drivers from, and uninstall the old ones while under safemode, reboot, and install the new ones, and reboot again.
Thank you Corrosive, that is basically what I did and everything worked out. I guess I downloaded a driver that was not compatible with my GPU (not sure how) but after removing the new one, the old one stepped back in and took over, everything is fine now.

Here are the steps I used (only did the first couple to remove the new one):
SCHawks73 is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
WTB SAPPHIRE Radeon HD 5850 SubFusion Buy/Sell/Trade and Hot Deals 0 09-23-2011 11:56 PM
Radeon 5850 Issues (maybe) SubFusion Hardware Repairs and Troubleshooting 0 03-31-2011 04:14 PM
Radeon 5850 flipp1234567 New Systems | Building and Buying 6 02-28-2011 06:14 PM
XFX Radeon 5850 syrendyr New Systems | Building and Buying 9 09-22-2010 09:40 AM
DIY Radeon HD 5850 2GB to Laptop Mod Osiris Laptops and Notebooks 1 06-01-2010 03:25 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:32 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.