ATI Catalyst Control Center NOT Working - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 05-16-2009, 05:07 PM   #1 (permalink)
Newb Techie
Join Date: May 2009
Posts: 1
Default ATI Catalyst Control Center NOT Working

I have an old ATI Radeon 9550, with the LATEST version of the Catalyst Control Center. I upgraded from Windows Vista to Windows 7 RC today, which stopped the CCC from working.

When I open it, it is running in task manager, but I cannot get into the interface. I have tried re-installing and even trying an older version, but none work. I am downloading the Vista/Win7 file (they are both the same on the ATI web site).

If anyone can help it'd be greatly appriciated. I need to get into there to enable a setting for my particular monitor.

I need the CCC because on my 1440x900 19" LG monitor, when "composite sync" isn't checked, the picture is squashed and there are black bars on either side, not sure why, it's weird.


MattBurley is offline  
Old 05-16-2009, 06:38 PM   #2 (permalink)
Wizard Techie
HAVOC's Avatar
Join Date: Feb 2005
Location: Milford, Connecticut
Posts: 4,218
Send a message via AIM to HAVOC Send a message via Yahoo to HAVOC
Default Re: ATI Catalyst Control Center NOT Working

First of all Matt, Welcome to Tech Forums.

Can you please list your system specs. Also, you said, "Upgraded to Windows 7 RC". You do realize that RC stands for (Release Candidate). Which is still a testing version of software. It's not recommended to use Win7RC on any primary personal or business PC as you are flying solo on tech support and troubleshooting. There is ZERO support right now for Win7RC. You must rely on yourself or others in the community for support. Not exactly a great situation to put yourself in.

ANYWAY... I'm gonna go out on a limb here. Take a look for me and find out which version of .NET Framework you have installed. I believe that you are having compatibility issues with .NET Framework, Win 7 and the Catalyst Control Panel GUI.

HAVOC is offline  
Old 05-16-2009, 10:04 PM   #3 (permalink)
Call me Mak or K
Mod Emeritus
KSoD's Avatar
Join Date: Sep 2004
Location: C:\
Posts: 35,647
Default Re: ATI Catalyst Control Center NOT Working

Windows 7 RC comes with .NET 3.5. So the .NET shouldnt be a issue as it should be up to date with the most current one. I would try removing teh ATi CCC and reinstalling it from scratch.
I do not accept support questions via EMail, PM, IM or my G+ page!

Phone: LG Optimus G Pro
Running: Stock JB from LG with Nova Launcher

KSoD is offline  
Old 05-16-2009, 11:27 PM   #4 (permalink)
Wizard Techie
HAVOC's Avatar
Join Date: Feb 2005
Location: Milford, Connecticut
Posts: 4,218
Send a message via AIM to HAVOC Send a message via Yahoo to HAVOC
Default Re: ATI Catalyst Control Center NOT Working

I found this in the AMD forums.

I had exact the same problem in windows 7 rc1 x64. The thing is that the ati driver is not installed by the catalyst install manager.You have to install it manually and then the catalyst control center will open.

Open the device manager and under display adapters you 'll see ati radeon...

right click on it and select update driver

select browse my computer and then select the folder packages\drivers\display\lh_inf (which is inside the folder where the drivers were extracted) and press ok

it will search and install the driver
worth a shot
HAVOC is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Tech Forums Official Crysis [Warhead] GPU Benchmark Thread gurusan Overclocking and Modding 543 03-11-2010 11:32 PM
Nvidia 178.13 drivers not working with ATI Tool .26 Gabb Overclocking and Modding 16 10-14-2008 04:41 PM
Trying to get IR remote control working in MCE nik_newland Microsoft Windows and Software 3 10-08-2008 02:27 PM
ATI gfx card in nforce4 mobo cwiz Hardware Repairs and Troubleshooting 8 09-07-2008 11:20 AM
Media Center not working dwaynesox Microsoft XBox 11 03-22-2008 01:43 PM

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:59 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.