Antec TruePower clicking noise - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 11-17-2006, 10:55 AM   #1 (permalink)
True Techie
Join Date: Mar 2006
Posts: 249
Default Antec TruePower clicking noise

Just bought an Antec Truepower Trio 430 ATX PSU for my HP. The problem I'm having is when I start-up every time the PSU makes a clicking sound like the internal fan is hitting something. It's not a really loud sound like it's ruining some wire in there, but annoyingnone-the-less. I haven't taken it back to Best Buy yet because the clicking goes away after 5 minutes. I'm assuming as the PSU gets hotter things are just working better or the fan speed kicks up and doesn't hit anything. Any ideas???

Here's the link to it:
Timaphillips is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:52 PM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.