Alpine 750 watt psu not working - Page 2 - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Click Here to Login
Closed Thread
 
Thread Tools Display Modes
 
Old 04-12-2011, 06:06 PM   #11 (permalink)
Techie Beyond Description
 
MindoverMaster's Avatar
 
Join Date: Dec 2009
Location: /home
Posts: 12,212
Send a message via MSN to MindoverMaster
Default Re: Alpine 750 watt psu not working

Every retailer sells the good and the bad. They don't test it. They just get it in and sell it. You just need to investigate every piece of hardware.
__________________

__________________
Neowin.net Steam Account
MindoverMaster is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
What's the difference between AMD's 1055T 125 watt version and the 95 watt version? soarwitheagles New Systems | Building and Buying 4 10-23-2010 05:12 PM
Old School Linux email with Alpine Osiris Linux Tips and Tricks 0 03-05-2009 07:39 PM
750 watt power supply vs. 1000 watt power supply Greenplantseed New Systems | Building and Buying 9 12-13-2006 11:48 AM
380 watt vs 430 watt computer PSU rookie1010 Monitors, Printers and Peripherals 7 12-17-2004 06:02 AM
380 Watt (Antec TruePower) Enough? Or 480 Watt? ag3 Monitors, Printers and Peripherals 2 06-18-2004 10:05 AM



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:26 AM.


Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.