8800GT, BSOD's / nv4_disp.dll crashes and loops. - Techist - Tech Forum

Go Back   Techist - Tech Forum > Computer Hardware > Hardware Repairs and Troubleshooting
Closed Thread
Thread Tools Display Modes
Old 12-24-2007, 08:24 AM   #1 (permalink)
True Techie
Join Date: Jan 2007
Posts: 151
Default 8800GT, BSOD's / nv4_disp.dll crashes and loops.

Hi, we recently bought a computer for my brother, and everything boots up fine and games play good, but it keeps getting the BSOD whilst gaming and loops and such.

His card is a Gigabyte 8800GT, the BSOD used to stay on a while so we could see the error, but now it happens so fast we can't see what it says, but it used to say nv4_disp.dll.

here are the things we've tried;

reinstalling windows
a different harddrive
different nvidia drivers & completely cleaning them using drivercleaner or something.
taking 1 stick of ram out, then the other.
made sure everythigns connected properly

and soon we're going to try a different graphics card in his computer to see if it is actually his graphics card or what?

could it be a faulty gcard?

here are the specs.

Gigabyte GA-P35C-DS3R Socket 775 8 Channel Audio ATX Motherboard
Intel Pentium Dual Core E2180 2GHz Socket 775 800MHz FSB L2 1MB Cache Retail Box Processor
Arctic Cooling AC-FRZ-7P Freezer 7 Pro Socket 775 Processor Coole
Crucial Ballistix 2GB Kit (2x1GB) DDR2 667MHz/PC2-5300 CL3 2.1 V unbuffered non-ECC
Corsair VX 550W PSU - 120mm Fan, 5 Year Warranty -
Gigabyte 8800GT 512MB GDDR3 Dual DVI PCI-E Graphics Card

any help is appreciated, we're going to try a different graphics card and if it persists most likely send the Gcard back, what else could it be?

Intel Core 2 Duo E6600, 2.4 GHz,
512MB EVGA 7950GT
Gigabyte GA 965P-DS3
2GB CorsairTwinX XMS2, DDR2 PC2-6400
580W HiperPower Type-R BLUE.
Antec Nine Hundred
Goodmans 19\'\' widescreen
Adzh is offline  
Old 12-26-2007, 06:33 AM   #2 (permalink)
[$m] Steele Muffins
<[MaTT]>'s Avatar
Join Date: Dec 2006
Location: Melbourne, Australia
Posts: 466
Default Re: 8800GT, BSOD's / nv4_disp.dll crashes and loops.

If youve done all those things youve said it must be a faulty gpu, bad luck man.

Test with a new card and reinstall drivers and dl the latest drivers again.

EDIT: oh yer and if the error is to fast just quickly take a screenshot
<a href="http://profile.xfire.com/sykomatt"><img src="http://miniprofile.xfire.com/bg/bg/type/2/sykomatt.png" width="450" height="34" /></a>
<[MaTT]> is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:40 AM.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2016, vBulletin Solutions, Inc.